mpg123 getauthfromurl buffer overflow

mpg123-getauthfromurl-bo (17574) The risk level is classified as HighHigh Risk

Description:

mpg123 is vulnerable to a buffer overflow in the getauthfromURL function. By creating a specially-crafted playlist containing a long URL, a remote attacker can overflow a buffer and possibly execute arbitrary code on the system, once the playlist is opened using mpg123.


Consequences:

Gain Access

Remedy:

For Gentoo Linux:
Upgrade to the latest version of mpg123 (0.59s-r5 or later), as listed in GLSA 200410-27. See References.

For Debian GNU/Linux 3.0 (alias woody):
Upgrade to the latest mpg123 package (0.59r-13woody4 or later), as listed in DSA-578-1. See References.

For Mandrake Linux:
Upgrade to the latest mpg123 package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:120 for more information. See References.

Mandrake Linux 10.1: 0.59r-22.1.101mdk or later
Mandrake Linux Corporate Server 2.1: 0.59r-21.2.C21mdk or later
Mandrake Linux 10.0: 0.59r-22.1.100mdk or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • BugTraq Mailing List, Tue Oct 19 2004 - 22:19:42 CDT: mpg123 "getauthfromurl" buffer overflow.
  • mpg123 Web site: mpg123, Fast MP3 Player for Linux and UNIX systems.
  • BID-11468: MPG123 Remote URL Open Buffer Overflow Vulnerability
  • CVE-2004-0982: Buffer overflow in the getauthfromURL function in httpget.c in mpg123 pre0.59s and mpg123 0.59r could allow remote attackers or local users to execute arbitrary code via an mp3 file that contains a long string before the @ (at sign) in a URL.
  • DSA-578: mpg123 -- buffer overflow
  • GLSA-200410-27: mpg123: Buffer overflow vulnerabilities
  • MDKSA-2004:120: Updated mpg123 packages fix vulnerability
  • OSVDB ID: 11023: mpg123 getauthfromURL() httpauth1 Remote Buffer Overflow
  • OSVDB ID: 27050: mpg123 on Gentoo Linux httpdget.c URL Handling Overflow
  • SA12908: mpg123 "getauthfromURL()" Buffer Overflow Vulnerability
  • SECTRACK ID: 1011832: mpg123 Buffer Overflow in getauthformURL() May Let Remote Users Execute Arbitrary Code
  • SUSE-SR:2005:002: SUSE Security Summary Report

Platforms Affected:

  • Debian Debian Linux 3.0
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 10.0 AMD64
  • MandrakeSoft Mandrake Linux 10.0
  • MandrakeSoft Mandrake Linux 10.1
  • MandrakeSoft Mandrake Linux 10.1 X86_64
  • MandrakeSoft Mandrake Linux Corporate Server 2.1 X86_64
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
  • mpg123 mpg123 0.59 r
  • mpg123 mpg123 pre0.59s

Reported:

Oct 19, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page