XPDF multiple integer overflows
|xpdf-pdf-file-bo (17819)||High Risk|
XPDF is vulnerable to multiple unspecified integer overflows. A remote attacker could exploit these vulnerabilities to execute arbitrary code on the system or cause the affected application to crash, if the attacker could persuade the victim to open a malicious PDF document.
Note: This vulnerability also affects other applications that are based off of the XPDF code, including CUPS, gpdf and kdegraphics.
For Gentoo Linux containing the xpdf package:
Upgrade to the latest version of xpdf (3.00-r5 or later), as listed in GLSA 200410-20. See References.
For Gentoo Linux containing the cups package:
Upgrade to the latest version of cups (1.1.20-r5 or later), as listed in GLSA 200410-20. See References.
For Gentoo Linux containing the gpdf package:
Upgrade to the latest version of gpdf (0.132-r2 or later), as listed in GLSA 200410-30. See References.
For Gentoo Linux containing the kdegraphics package:
Upgrade to the latest version of kdegraphics (3.3.0-r2 or later), as listed in GLSA 200410-30. See References.
For Gentoo Linux containing the koffice package:
Upgrade to the latest version of koffice (1.3.3-r2 or later), as listed in GLSA 200410-30. See References.
For Mandrake Linux:
Upgrade to the latest xpdf package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:113 for more information. See References.
Mandrake Linux Corporate Server 2.1: 3.00-5.2.100mdk or later
Mandrake Linux 10.0: 3.00-5.2.100mdk or later
Apply the appropriate patch for your system, as listed in KDE Security Advisory 20041021-1. See References.
For SuSE Linux:
Upgrade to the latest xpdf, gpdf, kdegraphics3-pdf, pdftohtml or cups package, as listed in SuSE Security Announcement SUSE-SA:2004:039 for more information. See References.
For SuSE Linux:
Apply the appropriate fixed packages via the SuSE FTP server or the YaST Online Update, as listed in SuSE Security Summary Report SUSE-SR:2004:002. See References.
For Ubuntu Linux 4.10:
Upgrade to the latest xpdf-reader, xpdf-utils, cupsys, and tetex-bin package (3.00-8ubuntu1.2, 1.1.20final+cvs20040330-4ubuntu16.2 or 2.0.2-21ubuntu0.2 or later), as listed in Ubuntu Security Notice 14-1 November 1, 2004. See References.
For Conectiva Linux:
Upgrade to the latest xpdf package, as listed below. Refer to Conectiva Linux Security Announcement CLSA-2004:886 for more information. See References.
Conectiva Linux 10.0: 3.00-48231U10_1cl or later
Conectiva Linux 9: 2.01-22930U90_2cl or later
For other distributions:
Contact your vendor for upgrade or patch information.
- Conectiva Linux Security Announcement CLSA-2004:886: Fixes for xpdf vulnerabilities.
- Xpdf Web site: Xpdf.
- BID-11501: Xpdf PDFTOPS Multiple Integer Overflow Vulnerabilities
- CVE-2004-0889: Multiple integer overflows in xpdf 3.0, and other packages that use xpdf code such as CUPS, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code, a different set of vulnerabilities than those identified by CVE-2004-0888.
- GLSA-200410-20: Xpdf, CUPS: Multiple integer overflows
- GLSA-200410-30: GPdf, KPDF, KOffice: Vulnerabilities in included xpdf
- GLSA-200501-31: teTeX, pTeX, CSTeX: Multiple vulnerabilities
- MDKSA-2004:113: Updated xpdf packages fix vulnerabilities
- OSVDB ID: 11033: Xpdf indexHigh Color Size Remote Overflow
- OSVDB ID: 11034: Xpdf Page Size Remote Overflow
- SUSE-SA:2004:038: libtiff: local privilege escalation
- SUSE-SA:2004:039: xpdf gpdf kdegraphics3-pdf pdftohtml cups: remote system compromise
- SUSE-SA:2004:040: samba: remote denial of service
- SUSE-SR:2004:002: SUSE Security Summary Report
- SUSE-SR:2005:008: SUSE Security Summary Report
- USN-14-1: xpdf vulnerabilities
- USN-2-1: xpdf vulnerabilities
- Canonical Ubuntu 4.10
- Conectiva Linux 10
- Conectiva Linux 9.0
- Easy Software Products CUPS
- Foolabs Xpdf 3.0
- Gentoo Linux
- KDE KDE 3.2.x
- KDE KDE 3.3.0
- KDE KDE 3.3.1
- MandrakeSoft Mandrake Linux 10.0
- MandrakeSoft Mandrake Linux 10.0 AMD64
- MandrakeSoft Mandrake Linux 10.1
- MandrakeSoft Mandrake Linux 10.1 X86_64
- MandrakeSoft Mandrake Linux Corporate Server 2.1
- MandrakeSoft Mandrake Linux Corporate Server 2.1 X86_64
- Novell Linux Desktop 9
- SuSE Linux Enterprise Server 8
- SuSE Linux Enterprise Server 9
- SUSE SuSE Linux 8.1
- SUSE SuSE Linux 8.2
- SUSE SuSE Linux 9.0
- SUSE SuSE Linux 9.1
- SUSE SuSE Linux 9.2
- SUSE SuSE Linux
- SuSE SuSE Linux Desktop 1.0
Oct 21, 2004
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this