Libxml2 nanohttp.c file buffer overflow

libxml2-nanohttp-file-bo (17876) The risk level is classified as HighHigh Risk

Description:

Libxml2 is vulnerable to a buffer overflow in the xmlNanoHTTPConnectHost function of the nanohttp.c file. A remote attacker, in control of a DNS server, can supply a malicious DNS reply to overflow a buffer and possibly execute arbitrary code on the system.


Consequences:

Gain Access

Remedy:

For Red Hat Linux containing the libxml package:
Upgrade to the latest libxml package, as listed below. Refer to RHSA-2004:650-03 for more information. See References.

Red Hat Enterprise Linux AS (v. 2.1), ES (v. 2.1), WS (vs. 2.1), and Advanced Workstation 2.1 for the Itanium Processor: 1.8.14-3 or later
Red Hat Enterprise Linux Red Hat Desktop (v. 3), AS (v. 3), ES (v. 3), WS (v. 3): 1.8.17-9.2 or later

For Trustix Secure Linux:
Upgrade to the latest libxml2 package, as listed below. Refer to Trustix Secure Linux Security Advisory #2004-0055 for more information. See References.

Trustix Secure Linux 2.0: 2.6.15-0.1tr or later
Trustix Secure Linux 2.1 and Enterprise Linux 2: 2.6.15-1tr or later
Trustix Operating System - Enterprise Server 2: 2.6.15-1tr or later

For Debian GNU/Linux 3.0 (alias woody):
Upgrade to the latest libxml package (1.8.17-2woody2 or later), as listed in DSA-582-1. See References.

For Gentoo Linux:
Upgrade to the latest version of libxml2 (2.6.15 or later), as listed in GLSA 200411-05. See References.

For Ubuntu Linux:
Upgrade to the latest libxml2 package (2.6.11-3ubuntu1.1 or later), as listed in USN-10-1 October 28, 2004. See References.

For Turbolinux:
Upgrade to the latest libxml package, as listed below. Refer to Turbolinux Security Advisory TLSA-2005-11 for more information. See References.

Turbolinux Appliance Server 1.0 Hosting Edition: 1.8.17-3 or later
Turbolinux Appliance Server 1.0 Workgroup Edition: 1.8.17-3 or later
Turbolinux Home: 1.8.17-3 or later
Turbolinux 10 Desktop: 1.8.17-3 or later
Turbolinux 8 Server: 1.8.17-3 or later
Turbolinux 8 Workstation: 1.8.17-3 or later
Turbolinux 7 Server: 1.8.14-2 or later
Turbolinux 7 Workstation: 1.8.14-2 or later

For Turbolinux:
Upgrade to the latest libxml2 package, as listed below. Refer to Turbolinux Security Advisory TLSA-2005-12 for more information. See References.

Turbolinux Appliance Server 1.0 Hosting Edition: 2.4.22-3 or later
Turbolinux Appliance Server 1.0 Workgroup Edition: 2.4.22-3 or later
Turbolinux 10 Server: 2.6.11-3 or later
Turbolinux Home: 2.6.2-3 or later
Turbolinux 10 Desktop: 2.6.2-3 or later
Turbolinux 8 Server: 2.4.22-3 or later
Turbolinux 8 Workstation: 2.4.19-3 or later
Turbolinux 7 Server: 2.4.28-3 or later
Turbolinux 7 Workstation: 2.4.28-3 or later

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Canonical Ubuntu 4.10
  • Debian Debian Linux 3.0
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 10.0
  • MandrakeSoft Mandrake Linux 10.0 AMD64
  • MandrakeSoft Mandrake Linux 10.1 X86_64
  • MandrakeSoft Mandrake Linux 10.1
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
  • MandrakeSoft Mandrake Linux Corporate Server 2.1 X86_64
  • Novell Linux Desktop 9
  • OpenPKG OpenPKG 2.1
  • OpenPKG OpenPKG 2.2
  • OpenPKG OpenPKG CURRENT
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SuSE Linux Enterprise Server 9
  • SUSE SuSE Linux 9.1
  • SUSE SuSE Linux 9.2
  • Trustix Enterprise Server 2
  • Trustix Secure Linux 2.0
  • Trustix Secure Linux 2.1
  • Turbolinux Turbolinux 10 Desktop
  • Turbolinux Turbolinux 10 F...
  • Turbolinux Turbolinux 10 Server
  • Turbolinux Turbolinux 7 Server
  • Turbolinux Turbolinux 7 Workstation
  • Turbolinux Turbolinux 8 Server
  • Turbolinux Turbolinux 8 Workstation
  • Turbolinux Turbolinux Appliance Server 1.0
  • Turbolinux Turbolinux Home
  • Turbolinux Turbolinux Appliance Server 1.0 Hosting Ed
  • Turbolinux Turbolinux Appliance Server 1.0 Workgroup Ed
  • XMLsoft Libxml2 2.6.12
  • XMLsoft Libxml2 2.6.13

Reported:

Oct 25, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page