libXpm directory traversal

libxpm-directory-traversal (18146) The risk level is classified as MediumMedium Risk

Description:

libXpm (X Pixmap library) could allow a remote attacker to traverse directories on the system.


Consequences:

Obtain Information

Remedy:

For libXpm 6.8.0:
Apply the xorg-680-CAN-2004-0914 patch, available from the X.Org Foundation Web site. See References.

For libXpm 6.8.1:
Apply the xorg-681-CAN-2004-0914 patch, available from the X.Org Foundation Web site. See References.

For SuSE Linux containing the xshared package:
Upgrade to the latest xshared package, as listed below. Refer to SuSE Security Announcement SUSE-SA:2004:041 for more information. See References.

SuSE Linux 8.1: 4.2.0-269 or later

For SuSE Linux containing the XFree86-libs package:
Upgrade to the latest XFree86-libs package, as listed below. Refer to SuSE Security Announcement SUSE-SA:2004:041 for more information. See References.

SuSE Linux 9.1: 4.3.99.902-43.35.3 or later
SuSE Linux 9.0: 4.3.0.1-57 or later
SuSE Linux 8.2: 4.3.0-132 or later
SuSE Linux 8.1: 4.2.0-269 or later

For SuSE Linux containing the xorg-x11-libs package:
Upgrade to the latest xorg-x11-libs package, as listed below. Refer to SuSE Security Announcement SUSE-SA:2004:041 for more information. See References.

x86 Platform:
SuSE Linux 9.2: 6.8.1-15.3 or later

x86-64 Platform:
SuSE Linux 9.2: 9.2-200411100529 or later

For Gentoo Linux:
Upgrade to the latest version of X.Org, XFree86, as listed in GLSA 200411-28. See References.

For Mandrake Linux:
Upgrade to the latest libxpm4 package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:137 for more information. See References.

Mandrake Linux 10.1: 3.4k-28.1.101mdk or later
Mandrake Linux 9.2: 3.4k-27.2.92mdk or later
Mandrake Linux Multi Network Firewall 8.2: 1.3.23-4.4.M82mdk or later
Mandrake Linux Corporate Server 2.1: 3.4k-21.2.C21mdk or later
Mandrake Linux 10.0: 3.4k-27.2.100mdk or later

For Mandrake Linux containing the XFree86 package:
Upgrade to the latest XFree86 package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2004:138 for more information. See References.

Mandrake Linux 10.1: 6.7.0-4.2.101mdk or later
Mandrake Linux 9.2: 4.3-24.6.92mdk or later
Mandrake Linux Multi Network Firewall 8.2: 1.3.23-4.4.M82mdk or later
Mandrake Linux Corporate Server 2.1: 4.2.1-6.11.C21mdk or later
Mandrake Linux 10.0: 4.3-32.3.100mdk or later

For Red Hat Linux containing the openmotif package:
Upgrade to the latest openmotif package, as listed below. Refer to RHSA-2004:537-17 for more information. See References.

Red Hat Enterprise Linux AS, ES, WS (v. 3) and Desktop 3: 2.2.3-4.RHEL3.4 or later
Red Hat Enterprise Linux AS, ES, WS (v. 2.1) and Red Hat Linux Advanced Workstation 2.1: 2.1.30-13.21AS.4 or later

For Red Hat Linux containing the XFree86 package:
Upgrade to the latest XFree86 package, as listed below. Refer to RHSA-2004:610-13 for more information. See References.

Red Hat Enterprise Linux AS, ES, WS (v. 2.1) and Red Hat Linux Advanced Workstation 2.1: 4.1.0-64.EL or later

For Red Hat Linux containing the XFree86 package:
Upgrade to the latest XFree86 package, as listed below. Refer to RHSA-2004:612-13 for more information. See References.

Red Hat Enterprise Linux AS, ES, WS (v. 3) and Red Hat Desktop: 4.3.0-78.EL or later

For Red Hat Linux (lesstif):
Refer to RHSA-2005:004-12 for patch, upgrade, or suggested workaround information. See References.

For Fedora Core 2:
Upgrade to the latest xorg-x11 package (6.7.0-10 or later), as listed in Fedora Update Notification FEDORA-2004-4334. See References.

For Fedora Core 3:
Upgrade to the latest xorg-x11 package (6.8.1-12.FC3.1 or later), as listed in Fedora Update Notification FEDORA-2004-434. See References.

For Turbolinux:
Upgrade to the latest XFree86 package, as listed below. Refer to Turbolinux Security Advisory TLSA-2005-5 for more information. See References.

Turbolinux 10 Server: 4.3.0-77 or later
Turbolinux Home: 4.3.0-77 or later
Turbolinux 10 Desktop: 4.3.0-77 or later
Turbolinux 8 Server: 4.2.0-31 or later
Turbolinux 8 Workstation: 4.2.0-31 or later
Turbolinux 7 Server: 4.1.0-40 or later
Turbolinux 7 Workstation: 4.1.0-40 or later

For Gentoo Linux:
Upgrade to the latest version of lesstiff (0.94.0 or later), as listed in GLSA 200502-06. See References.

For Gentoo Linux (openmotif):
Refer to Gentoo Linux Security Announcement GLSA 2005-02-07 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • Fedora Update Notification FEDORA-2004-433: xorg-x11-6.7.0-10 update.
  • Fedora Update Notification FEDORA-2004-434: xorg-x11-6.8.1-12.FC3.1 update.
  • X.Org Foundation Web site: X.Org.
  • BID-11694: LibXPM Multiple Unspecified Vulnerabilities
  • CVE-2004-0914: Multiple vulnerabilities in libXpm for 6.8.1 and earlier, as used in XFree86 and other packages, include (1) multiple integer overflows, (2) out-of-bounds memory accesses, (3) directory traversal, (4) shell metacharacter, (5) endless loops, and (6) memory leaks, which could allow remote attackers to obtain sensitive information, cause a denial of service (application crash), or execute arbitrary code via a certain XPM image file. NOTE: it is highly likely that this candidate will be SPLIT into other candidates in the future, per CVE's content decisions.
  • DSA-607: xfree86 -- several vulnerabilities
  • GLSA-200411-28: X.Org, XFree86: libXpm vulnerabilities
  • GLSA-200502-06: LessTif: Multiple vulnerabilities in libXpm
  • GLSA-200502-07: OpenMotif: Multiple vulnerabilities in libXpm
  • MDKSA-2004:137: Updated libxpm4 packages fix libXpm vulnerabilities
  • MDKSA-2004:137-1: Updated libxpm4 packages correct issues with previous update
  • MDKSA-2004:138: Updated XFree86 packages fix libXpm vulnerabilities
  • RHSA-2004-537: openmotif security update
  • RHSA-2004-610: XFree86 security update
  • RHSA-2004-612: XFree86 security update
  • RHSA-2005-004: lesstif security update
  • RHSA-2008-0524: Low: Red Hat Network Satellite Server security update
  • SA13224: X11 libXpm Multiple Image Processing Vulnerabilities

Platforms Affected:

  • Canonical Ubuntu 4.10
  • Debian Debian Linux 3.0
  • FedoraProject Fedora Core 2
  • FedoraProject Fedora Core 3
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 10.0
  • MandrakeSoft Mandrake Linux 10.0 AMD64
  • MandrakeSoft Mandrake Linux 10.1 X86_64
  • MandrakeSoft Mandrake Linux 10.1
  • MandrakeSoft Mandrake Linux 9.2
  • MandrakeSoft Mandrake Linux 9.2 AMD64
  • MandrakeSoft Mandrake Linux Corporate Server 2.1
  • MandrakeSoft Mandrake Linux Corporate Server 2.1 X86_64
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 AW
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 ES
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • RedHat Network Satellite Server 4.2
  • SuSE Linux Enterprise Server 8
  • SUSE SuSE Linux 8.1
  • SUSE SuSE Linux 8.2
  • SUSE SuSE Linux 9.0
  • SUSE SuSE Linux 9.1
  • SUSE SuSE Linux 9.2
  • SuSE SuSE Linux Desktop 1.0
  • SuSE SuSE SLES 9
  • Turbolinux Turbolinux 10 Desktop
  • Turbolinux Turbolinux 10 F...
  • Turbolinux Turbolinux 10 Server
  • Turbolinux Turbolinux 7 Server
  • Turbolinux Turbolinux 7 Workstation
  • Turbolinux Turbolinux 8 Server
  • Turbolinux Turbolinux 8 Workstation
  • Turbolinux Turbolinux Home
  • X.Org libXpm 6.8.1

Reported:

Nov 17, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page