Linux kernel load_elf_binary denial of service

linux-loadelfbinary-dos (18687) The risk level is classified as MediumMedium Risk

Description:

Linux kernel is vulnerable to a denial of service attack, caused by a vulnerability in the load_elf_binary. By creating a specially-crafted ELF binary, a local attacker could cause the system to crash, once the binary is handled.


Consequences:

Denial of Service

Remedy:

Upgrade to the latest Kernel version (2.4.26 or later), available from the Linux kernel Web site. See References.

For Red Hat Linux:
Upgrade to the latest kernel package, as listed below. Refer to Red Hat Security Advisory RHSA-2004:689-06, RHSA-2005:016-13, or RHSA-2005:017-14 for more information. See References.

For Debian GNU/Linux:
Refer to DSA-1070-1, DSA-1069-1, DSA-1067-1, or DSA-1082-1 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Debian Debian Linux 3.0
  • Linux Kernel 2.4.0 test4
  • Linux Kernel 2.4.0 test9
  • Linux Kernel 2.4.0 test8
  • Linux Kernel 2.4.0 test7
  • Linux Kernel 2.4.0 test6
  • Linux Kernel 2.4.0 test5
  • Linux Kernel 2.4.0 test3
  • Linux Kernel 2.4.0 test2
  • Linux Kernel 2.4.0 test12
  • Linux Kernel 2.4.0 test11
  • Linux Kernel 2.4.0 test10
  • Linux Kernel 2.4.0 test1
  • Linux Kernel 2.4.0
  • Linux Kernel 2.4.1
  • Linux Kernel 2.4.10
  • Linux Kernel 2.4.11 pre2
  • Linux Kernel 2.4.11 pre1
  • Linux Kernel 2.4.11
  • Linux Kernel 2.4.11 pre3
  • Linux Kernel 2.4.12
  • Linux Kernel 2.4.13
  • Linux Kernel 2.4.14
  • Linux Kernel 2.4.15
  • Linux Kernel 2.4.16
  • Linux Kernel 2.4.17
  • Linux Kernel 2.4.18
  • Linux Kernel 2.4.18 pre4
  • Linux Kernel 2.4.18 pre9
  • Linux Kernel 2.4.18 pre8
  • Linux Kernel 2.4.18 pre7
  • Linux Kernel 2.4.18 pre6
  • Linux Kernel 2.4.18 pre5
  • Linux Kernel 2.4.18 pre3
  • Linux Kernel 2.4.18 pre2
  • Linux Kernel 2.4.18 pre1
  • Linux Kernel 2.4.19 pre2
  • Linux Kernel 2.4.19 pre4
  • Linux Kernel 2.4.19 pre1
  • Linux Kernel 2.4.19 pre3
  • Linux Kernel 2.4.19
  • Linux Kernel 2.4.19 pre5
  • Linux Kernel 2.4.19 pre6
  • Linux Kernel 2.4.2
  • Linux Kernel 2.4.20
  • Linux Kernel 2.4.21 pre2
  • Linux Kernel 2.4.21
  • Linux Kernel 2.4.21 pre7
  • Linux Kernel 2.4.21 pre4
  • Linux Kernel 2.4.21 pre5
  • Linux Kernel 2.4.21 pre3
  • Linux Kernel 2.4.21 pre1
  • Linux Kernel 2.4.21 pre6
  • Linux Kernel 2.4.22 pre1
  • Linux Kernel 2.4.22 pre2
  • Linux Kernel 2.4.22 pre3
  • Linux Kernel 2.4.22 pre9
  • Linux Kernel 2.4.22 pre4
  • Linux Kernel 2.4.22 pre5
  • Linux Kernel 2.4.22 pre6
  • Linux Kernel 2.4.22 pre7
  • Linux Kernel 2.4.22 pre10
  • Linux Kernel 2.4.22 pre8
  • Linux Kernel 2.4.22
  • Linux Kernel 2.4.23
  • Linux Kernel 2.4.23 ow2
  • Linux Kernel 2.4.23 pre9
  • Linux Kernel 2.4.23 pre1
  • Linux Kernel 2.4.23 pre2
  • Linux Kernel 2.4.23 pre3
  • Linux Kernel 2.4.23 pre4
  • Linux Kernel 2.4.23 pre5
  • Linux Kernel 2.4.23 pre6
  • Linux Kernel 2.4.23 pre7
  • Linux Kernel 2.4.23 pre8
  • Linux Kernel 2.4.24
  • Linux Kernel 2.4.24 ow1
  • Linux Kernel 2.4.25
  • Linux Kernel 2.4.3 pre2
  • Linux Kernel 2.4.3
  • Linux Kernel 2.4.3 pre1
  • Linux Kernel 2.4.3 pre3
  • Linux Kernel 2.4.4
  • Linux Kernel 2.4.5
  • Linux Kernel 2.4.6
  • Linux Kernel 2.4.7
  • Linux Kernel 2.4.8
  • Linux Kernel 2.4.9 pre3
  • Linux Kernel 2.4.9 pre4
  • Linux Kernel 2.4.9 pre2
  • Linux Kernel 2.4.9 pre1
  • Linux Kernel 2.4.9 pre5
  • Linux Kernel 2.4.9
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux AS
  • RedHat Linux Advanced Workstation 2.1 Itanium

Reported:

Dec 23, 2004

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page