Midnight Commander format string attack

midnightcommander-format-string (18902) The risk level is classified as HighHigh Risk

Description:

Midnight Commander (mc) is vulnerable to a format string attack. A remote attacker could exploit this vulnerability to possibly cause the program to crash or execute arbitrary code on the system.


Consequences:

Gain Privileges

Remedy:

Reportedly, this has been fixed in the CVS repository.

For Debian GNU/Linux 3.0 (woody):
Upgrade to the latest version of mc (4.5.55-1.2woody5 or later), as listed in DSA-639-1. See References.

For Red Hat Linux:
Refer to RHSA-2005:217-10 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux:
Refer to Gentoo Linux Security Announcement GLSA 2005-02-24 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Debian Debian Linux 3.0
  • Gentoo Linux
  • GNOME Midnight Commander 4.x
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • Turbolinux Turbolinux 7 Server
  • Turbolinux Turbolinux 7 Workstation
  • Turbolinux Turbolinux 8 Server
  • Turbolinux Turbolinux 8 Workstation

Reported:

Jan 14, 2005

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page