phpMyAdmin multiple .php scripts cross-site scripting

phpmyadmin-multiple-php-xss (19462) The risk level is classified as MediumMedium Risk

Description:

phpMyAdmin is vulnerable to cross-site scripting. If register_globals is enabled, a remote attacker could send a specially-crafted URL request to the select_server.lib.php script containing embedded code in the strServer, cfg[BgcolorOne] or strServerChoice parameter, to the display_tbl_links.lib.php script containing embedded code in the bgcolor or row_no parameter, to the theme_left.css.php script containing embedded code in the left_font_family parameter, or to the theme_right.css.php script containing embedded code in the right_font_family parameter, which would be executed in the victim's Web browser within the security context of the hosting site, once the link is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of phpMyAdmin (2.6.1-pl1 or later), available from the phpMyAdmin Download Web page. See References.

For Gentoo Linux:
Upgrade to the latest version of phpMyAdmin (2.6.1_p2-r1 or later), as listed in GLSA200503-07. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • phpMyAdmin Download Web page: phpMyAdmin > Downloads | MySQL Database Administration Tool | www.phpmyadmin.net.
  • BID-12644: PHPMyAdmin Multiple Libraries And Themes Remote Cross-Site Scripting Vulnerabilities
  • CVE-2005-0543: Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.6.1 allows remote attackers to inject arbitrary HTML and web script via (1) the strServer, cfg[BgcolorOne], or strServerChoice parameters in select_server.lib.php, (2) the bg_color or row_no parameters in display_tbl_links.lib.php, the left_font_family parameter in theme_left.css.php, or the right_font_family parameter in theme_right.css.php.
  • GLSA-200503-07: phpMyAdmin: Multiple vulnerabilities
  • OSVDB ID: 14096: phpMyAdmin select_server.lib.php Multiple Parameter XSS
  • OSVDB ID: 14097: phpMyAdmin display_tbl_links.lib.php Multiple Parameter XSS
  • OSVDB ID: 14098: phpMyAdmin theme_left.css.php Multiple Parameter XSS
  • OSVDB ID: 14099: phpMyAdmin theme_right.css.php Multiple Parameter XSS
  • OSVDB ID: 14100: phpMyAdmin database_interface.lib.php cfg Parameter XSS
  • SA14382: phpMyAdmin Local File Inclusion and Cross-Site Scripting

Platforms Affected:

  • Gentoo Linux
  • phpMyAdmin phpMyAdmin 2.6.1

Reported:

Feb 24, 2005

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page