Racoon ISAKMP header denial of service

racoon-isakmp-header-dos (19707) The risk level is classified as MediumMedium Risk

Description:

Racoon is vulnerable to a denial of service attack caused by improper bounds checking of user-supplied information in the isakmp_quick.c, oakley.c, ipsec_doe.c, and isakmp.c header length field. A remote attacker could send a specially-crafted header to cause the ISAKMP service to crash.

Note: It is reported that ISKMP inform, quick, and base modes are also affected by this vulnerability.


Consequences:

Denial of Service

Remedy:

Apply the fix for this vulnerability, available from the KAME-snap kit Web page. See References.

For SUSE Linux:
Upgrade to the latest ipsec-tools, as listed below. Refer to SUSE Security Announcement SUSE-SA:2005:020 for more information. See References.

x86:
SUSE Linux 9.2: 0.4rc1-3.2 or later
SUSE Linux 9.1: 0.3.3-1.6 or later

For SGI:
Apply the appropriate patch for your system, as listed in SGI Security Advisory 20050304-01-U. See References.

For Conectiva Linux 10.0:
Upgrade to the latest version of ipsec-tools (0.5.2 or later), as listed in Conectiva Linux Security Announcement CLSA-2005:971. See References.

For Red Hat Linux:
Refer to RHSA-2005:232-10 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux:
Refer to Gentoo Linux Security Announcement GLSA 2005-03-33 for patch, upgrade, or suggested workaround information. See References.

For Ubuntu Linux:
Refer to USN-107-1 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Canonical Ubuntu 4.10
  • Conectiva Linux 10
  • Gentoo Linux
  • KAME Project Racoon
  • MandrakeSoft Mandrake Linux 10.0
  • MandrakeSoft Mandrake Linux 10.0 AMD64
  • MandrakeSoft Mandrake Linux 10.1
  • MandrakeSoft Mandrake Linux 10.1 X86_64
  • Novell Linux Desktop 9
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 4 WS
  • RedHat Enterprise Linux 4 AS
  • RedHat Enterprise Linux 4 Desktop
  • RedHat Enterprise Linux 4 ES
  • SuSE Linux Enterprise Server 9
  • SUSE SuSE Linux 9.1
  • SUSE SuSE Linux 9.2
  • SuSE SuSE SLES 9
  • Turbolinux Turbolinux 10 Server

Reported:

Mar 15, 2005

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page