Adobe Acrobat/Reader plug-in buffer overflow

adobe-acrobat-reader-plugin-bo (21860) The risk level is classified as HighHigh Risk

Description:

Adobe Reader is vulnerable to a buffer overflow caused by improper bounds checking in the core application plug-in. By sending a specially-crafted file, a remote attacker could overflow a buffer and execute arbitrary code on the system, or possibly cause a denial of service.


Consequences:

Gain Access

Remedy:

For Adobe Acrobat Reader for Microsoft Windows or Mac OS:
Upgrade to the latest version of Adobe Acrobat Reader (7.0.3 or 6.0.4 or later), available from the Adobe Systems Incorporated Downloads Web page. See References.

For Adobe Acrobat Reader for Linux or Solaris:
Upgrade to the latest version of Adobe Acrobat Reader (7.0.1 or later), available from the Adobe Systems Incorporated Downloads Web page. See References.

For Adobe Acrobat for Windows or Mac OS:
Upgrade to the latest version of Adobe Acrobat (7.0.3, 6.0.4, or 5.0.10 or later), available from the Adobe Systems Incorporated Downloads Web page. See References.

For Gentoo Linux:
Upgrade the latest version of Adobe Reader (7.0.1.1 or later), as listed in Gentoo Linux Security Announcement GLSA 200508-11. See Reference.

For SUSE Linux:
Upgrade to the latest version of acroread, as listed below. Refer to SUSE Security Announcement SUSE-SA:2005:04. See References.

X86 platform:
SUSE Linux 9.2 and 9.3: 7.0.1-2.1 or later
SUSE Linux 9.1: 7.0.1-2.2 or later
>SUSE Linux 9.0: 7.0.1-3 or later

For Red Hat Linux:
Refer to RHSA-2005:750-07 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Adobe Acrobat 5.0
  • Adobe Acrobat 5.0.5
  • Adobe Acrobat 6.0
  • Adobe Acrobat 6.0.1
  • Adobe Acrobat 6.0.2
  • Adobe Acrobat 7.0
  • Adobe Acrobat 7.0.1
  • Adobe Acrobat 7.0.2
  • Adobe Acrobat Reader 5.1
  • Adobe Acrobat Reader 6.0
  • Adobe Acrobat Reader 6.0.1
  • Adobe Acrobat Reader 6.0.2
  • Adobe Acrobat Reader 6.0.3
  • Adobe Acrobat Reader 7.0
  • Adobe Acrobat Reader 7.0.1
  • Adobe Acrobat Reader 7.0.2
  • Gentoo Linux
  • Novell Linux Desktop 9
  • Novell Open Enterprise 9 Server
  • Novell Open Enterprise Server
  • Novell Open Enterprise Server
  • RedHat RHEL Extras 3
  • RedHat RHEL Extras 4
  • SuSE Linux Enterprise Server 8
  • SuSE Linux Enterprise Server 9
  • SUSE SuSE Linux 9.0
  • SUSE SuSE Linux 9.1
  • SUSE SuSE Linux 9.2
  • SUSE SuSE Linux 9.3
  • SuSE SuSE Open Enterprise Server 9
  • SuSE SuSE SLES 9

Reported:

Aug 16, 2005

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page