xine-lib input_cdda.c format string

xinelib-inputcdda-format-string (22545) The risk level is classified as HighHigh Risk

Description:

xine vulnerable to a format string attack caused by a vulnerability in the input_cdda.c. This occurs when writing CD metadata that is retrieved from a CDDB server to a cache file. If a remote attacker modifies entries located on the CDDB server and persuades the user to connect to the malicious CDDB server or possibly to visit a malicious Web site containing embedded xine Audio CD MRL (Media Resource Locator), once the victim plays the CD, the attacker could overwrite arbitrary memory locations and execute arbitrary code on the victim's system with user privileges.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of xine-lib (1.0.3a or later), available from the xine Download Web page. See References.

— OR —

Apply the patch for this vulnerability, as listed in xine security announcement XSA-2005-1. See References.

For Debian GNU/Linux:
Refer to DSA-863-1 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux:
Refer to Gentoo Linux Security Announcement GLSA 2005-10-08 for patch, upgrade, or suggested workaround information. See References.

For Ubuntu Linux:
Refer to USN-196-1 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • xine Download Web page: Download and install xine-lib.
  • xine security announcement XSA-2005-1: Announcement-ID: XSA-2005-1.
  • xine Web site: xine - A Free Video Player.
  • BID-15044: Xine-Lib Remote CDDB Information Format String Vulnerability
  • CVE-2005-2967: Format string vulnerability in input_cdda.c in xine-lib 1-beta through 1-beta 3, 1-rc, 1.0 through 1.0.2, and 1.1.1 allows remote servers to execute arbitrary code via format string specifiers in metadata in CDDB server responses when the victim plays a CD.
  • DSA-863: xine-lib -- format string vulnerability
  • GLSA-200510-08: xine-lib: Format string vulnerability
  • MDKSA-2005:180: Updated xine-lib packages fixes cddb vulnerability
  • OSVDB ID: 19892: xine/gxine xine-lib CDDB Response Format String
  • SA17099: xine-lib CDDB Client Format String Vulnerability
  • SUSE-SR:2005:024: SUSE Security Summary Report
  • USN-196-1: Xine library vulnerability

Platforms Affected:

  • Canonical Ubuntu 4.10
  • Canonical Ubuntu 5.04
  • Debian Debian Linux 3.0
  • Debian Debian Linux 3.1
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 10.1 X86_64
  • MandrakeSoft Mandrake Linux 10.1
  • MandrakeSoft Mandrake Linux 2006 X86_64
  • MandrakeSoft Mandrake Linux 2006
  • MandrakeSoft Mandrake Linux LE2005 X86_64
  • MandrakeSoft Mandrake Linux LE2005
  • MandrakeSoft Mandrake Linux Corporate Server 3.0
  • MandrakeSoft Mandrake Linux Corporate Server 3.0 X86_64
  • Xine xine-lib 0.5 to 0.5.2
  • Xine xine-lib 1-beta to 1-beta3
  • Xine xine-lib 1-rc releases
  • Xine xine-lib 1.1.0 release

Reported:

Oct 10, 2005

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page