SimpleBlog month parameter SQL injection

simpleblog-month-sql-injection (24155) The risk level is classified as MediumMedium Risk

Description:

SimpleBlog is vulnerable to SQL injection. A remote attacker could send specially-crafted SQL statements using the month parameter, which could allow the attacker to add, modify, or delete information in the back-end database.


Consequences:

Data Manipulation

Remedy:

No remedy available as of September 1, 2014.

References:

  • BugTraq Mailing List, Sat Jan 14 2006 - 17:21:17 CST: [HSC Security Group] Multiple SQL injection/XSS in SimpleBlog 2.1.
  • SimpleBlog 2.1 Web site: Downloads - SimpleBlog 2.1.
  • BID-16243: 8Pixel.net SimpleBlog Multiple Input Validation Vulnerabilities
  • CVE-2006-0240: Multiple SQL injection vulnerabilities in Simple Blog 2.1 allow remote attackers to execute arbitrary SQL commands via the month parameter in an archives view operation and possibly certain other parameters in unspecified scripts.
  • OSVDB ID: 22447: SimpleBlog index.php month Parameter SQL Injection
  • SA18488: SimpleBlog Script Insertion and SQL Injection Vulnerabilities

Platforms Affected:

  • 8pixel.net SimpleBlog 2.1 and prior

Reported:

Jan 16, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page