F-Secure Anti-Virus ZIP file buffer overflow

fsecure-zip-bo (24198) The risk level is classified as HighHigh Risk

Description:

Multiple F-Secure Anti-Virus products are vulnerable to a buffer overflow when handling ZIP files. By sending a specially-crafted ZIP file to a vulnerable system, a remote attacker could overflow a buffer and execute arbitrary code on the system.


Consequences:

Gain Access

Remedy:

Refer to F-Secure Security Bulletin FSC-2006-1 for upgrade information. See References.

References:

  • F-Secure Security Bulletin FSC-2006-1: Code execution vulnerability in ZIP and RAR-archive handling.
  • BID-16309: F-Secure Multiple Archive Handling Vulnerabilities
  • CVE-2006-0337: Buffer overflow in multiple F-Secure Anti-Virus products and versions for Windows and Linux, including Anti-Virus for Windows Servers 5.52 and earlier, Internet Security 2004, 2005 and 2006, and Anti-Virus for Linux Servers 4.64 and earlier, allows remote attackers to execute arbitrary code via crafted ZIP archives.
  • OSVDB ID: 22632: F-Secure Anti-Virus ZIP Archive Processing Overflow
  • SA18529: F-Secure Anti-Virus Archive Handling Vulnerabilities
  • SECTRACK ID: 1015507: F-Secure Anti-Virus Buffer Overflow in Processing ZIP Archives Lets Remote Users Execute Arbitrary Code
  • SECTRACK ID: 1015508: F-Secure Internet Gatekeeper Buffer Overflow in Processing ZIP Archives Lets Remote Users Execute Arbitrary Code
  • SECTRACK ID: 1015509: F-Secure Personal Express Overflow in Processing ZIP Archives Lets Remote Users Execute Arbitrary Code
  • SECTRACK ID: 1015510: F-Secure Internet Security Buffer Overflow in Processing ZIP Archives Lets Remote Users Execute Arbitrary Code

Platforms Affected:

  • F-Secure Anti-Virus 2004
  • F-Secure Anti-Virus 2005
  • F-Secure Anti-Virus 2006
  • F-Secure Anti-Virus Client Security 6.01 and prior
  • F-Secure Anti-Virus for Citrix Servers 5.52
  • F-Secure Anti-Virus for Firewalls 6.20 and prior
  • F-Secure Anti-Virus for Linux Gateways 4.64 and prior
  • F-Secure Anti-Virus for Linux Servers 4.64 and prior
  • F-Secure Anti-Virus for Linux WS 4.52 and prior
  • F-Secure Anti-Virus for MIMEsweeper 5.61 and prior
  • F-Secure Anti-Virus for MS Exchange 6.40 and prior
  • F-Secure Anti-Virus for Samba Servers 4.62
  • F-Secure Anti-Virus for Windows Servers 5.52
  • F-Secure Anti-Virus for Workstation 5.44
  • F-Secure Anti-Virus Linux Client Sec 5.11 and prior
  • F-Secure Anti-Virus Linux Server Sec 5.11 and prior
  • F-Secure Internet Gatekeeper 6.42
  • F-Secure Internet Gatekeeper for Linux 2.14
  • F-Secure Internet Gatekeeper for Linux 2.x
  • F-Secure Internet Security 2004
  • F-Secure Internet Security 2005
  • F-Secure Internet Security 2006
  • F-Secure Personal Express 6.20 and prior

Reported:

Jan 19, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page