Tor hidden service information disclosure

tor-service-information-disclosure (24285) The risk level is classified as LowLow Risk

Description:

Tor could allow a remote attacker to obtain sensitive information. A design error in Tor could allow an attacker in control of a malicious Tor server to determine the location of a hidden service. The attacker could access the hidden service repeatedly to obtain sensitive information regarding Tor users.


Consequences:

Obtain Information

Remedy:

Upgrade to the latest version of Tor (0.1.1.12-alpha or later), available from the Tor Download Web page. See References.

For Gentoo Linux:
Refer to Gentoo Linux Security Announcement GLSA 2006-06-04 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Gentoo Linux
  • Tor Tor 0.1.1.10-a and prior

Reported:

Jan 23, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page