BEA WebLogic Server and Express connection filter denial of service

weblogic-connection-filter-dos (24301) The risk level is classified as MediumMedium Risk

Description:

BEA WebLogic Server and Express are vulnerable to a denial of service condition. Sites that have connection filters enabled will experience a decrease in server performance. This would provide an opportunity for a remote attacker to launch a denial of service attack.


Consequences:

Denial of Service

Remedy:

Refer to BEA Systems Inc. Security Advisory: (BEA06-117.00) for patch or upgrade information. See References.

References:

  • BEA Systems Inc. Security Advisory: (BEA06-117.00): Using a connection filter can cause the server to slow down .
  • BID-16358: BEA WebLogic Multiple Vulnerabilities
  • CVE-2006-0430: Certain configurations of BEA WebLogic Server and WebLogic Express 9.0, 8.1 through SP5, and 7.0 through SP6, when connection filters are enabled, cause the server to run more slowly, which makes it easier for remote attackers to cause a denial of service (server slowdown).
  • OSVDB ID: 22772: BEA WebLogic Connection Filters Unspecified Remote DoS
  • SA18592: BEA WebLogic Server/Express Vulnerabilities and Security Issues
  • SECTRACK ID: 1015528: BEA WebLogic Multiple Bugs Let Remote Users Deny Service, Obtain Information, and Access Restricted Resources

Platforms Affected:

  • Oracle WebLogic Server 7.0 SP4
  • Oracle WebLogic Server 7.0 SP5 Express
  • Oracle WebLogic Server 7.0 SP5
  • Oracle WebLogic Server 7.0 SP2 Express
  • Oracle WebLogic Server 7.0 SP6 Express
  • Oracle WebLogic Server 7.0 SP4 Express
  • Oracle WebLogic Server 7.0 SP3 Express
  • Oracle WebLogic Server 7.0 SP1 Express
  • Oracle WebLogic Server 7.0 SP3
  • Oracle WebLogic Server 7.0 SP2
  • Oracle WebLogic Server 7.0 SP1
  • Oracle WebLogic Server 7.0 SP6
  • Oracle WebLogic Server 8.1 SP1
  • Oracle WebLogic Server 8.1 SP1 Express
  • Oracle WebLogic Server 8.1 SP2
  • Oracle WebLogic Server 8.1 SP2 Express
  • Oracle WebLogic Server 8.1 SP3
  • Oracle WebLogic Server 8.1 SP3 Express
  • Oracle WebLogic Server 8.1 SP4
  • Oracle WebLogic Server 8.1 SP4 Express
  • Oracle WebLogic Server 9.0 SP3 Express
  • Oracle WebLogic Server 9.0 SP4 Express
  • Oracle WebLogic Server 9.0 SP2 Express
  • Oracle WebLogic Server 9.0 SP5
  • Oracle WebLogic Server 9.0 SP4
  • Oracle WebLogic Server 9.0 SP3
  • Oracle WebLogic Server 9.0 SP2
  • Oracle WebLogic Server 9.0 SP1
  • Oracle WebLogic Server 9.0 SP5 Express
  • Oracle WebLogic Server 9.0 SP1 Express

Reported:

Jan 23, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page