phpMyAdmin set_theme cross-site scripting
|phpmyadmin-settheme-xss (25305)||Medium Risk|
phpMyAdmin is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability using the set_theme parameter to execute script in a victim's Web browser within the security context of the hosting Web site, allowing the attacker to steal the victim's cookie-based authentication credentials.
Upgrade to the latest version of phpMyAdmin (184.108.40.206 or later), available from the phpMyAdmin Web site. See References.
- phpMyAdmin Web site: Downloads.
- BID-17142: PHPMyAdmin Set_Theme Cross-Site Scripting Vulnerability
- CVE-2006-1258: Cross-site scripting (XSS) vulnerability in phpMyAdmin 220.127.116.11 allows remote attackers to inject arbitrary web script or HTML via the set_theme parameter.
- OSVDB ID: 23943: phpMyAdmin set_theme XSS
- SA19277: phpMyAdmin "set_theme" Cross-Site Scripting
- SECTRACK ID: 1015776: phpMyAdmin Input Validation Flaw in `set_theme` Permits Cross-Site Scripting Attacks
- VUPEN/ADV-2006-0991: phpMyAdmin set_theme Parameter Handling Cross Site Scripting Vulnerability
- phpMyAdmin phpMyAdmin 18.104.22.168
Mar 17, 2006
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this