Apple Mac OS X CFAllocatorAllocate() buffer overflow

macosx-cfallocatorallocate-bo (25949) The risk level is classified as HighHigh Risk

Description:

Apple Mac OS X is vulnerable to a heap-based buffer overflow in the CFAllocatorAllocate() function. By creating a malicious GIF file and persuading a victim to open the file using either Safari or the Preview application, a remote attacker could overflow a buffer and cause the affected application to crash or possibly execute arbitrary code on the system. An attacker could exploit this vulnerability by hosting the malicious file on a Web site or sending it to a victim as an email attachment.


Consequences:

Gain Access

Remedy:

Upgrade to the latest updade for Apple Mac OS X Safari (2006-003 or later), available from the Apple Web site. See References.

References:

  • Security-Protocols Advisory April 19th, 2006: Apple OS X 10.4.6 "CFAllocatorAllocate ()" .gif Heap Overflow.
  • BID-17634: Apple Mac OS X Multiple Security Vulnerabilities
  • BID-17951: Apple Mac OS X Security Update 2006-003 Multiple Vulnerabilities
  • CVE-2006-1983: Multiple heap-based buffer overflows in Mac OS X 10.4.6 and earlier allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) PredictorVSetField function for TIFF or (2) CFAllocatorAllocate function for GIF, as used in applications that use ImageIO or AppKit. NOTE: the BMP vector has been re-assigned to CVE-2006-2238 because it affects a separate product family.
  • OSVDB ID: 24821: Apple Mac OS X .gif Processing CFAllocatorAllocate() Function Overflow
  • OSVDB ID: 24822: Apple Mac OS X .tiff Processing Multiple Function DoS
  • SA19686: Mac OS X Multiple Potential Vulnerabilities
  • SA20077: Mac OS X Security Update Fixes Multiple Vulnerabilities
  • SECTRACK ID: 1016067: Apple QuickTime Buffer Overflows in Processing JPEG/BMP/FlashPix/PICT Images and QuickTime/AVI/MPEG4/Flash Movies Let Remote Users Execute Arbitrary Code
  • VUPEN/ADV-2006-1452: Apple Mac OS X Multiple Client-Side File Handling Buffer Overflow Vulnerability
  • VUPEN/ADV-2006-1779: Apple Mac OS X Multiple Remote and Client-Side Code Execution Vulnerabilities

Platforms Affected:

  • Apple Mac OS X 10.3
  • Apple Mac OS X 10.3.1
  • Apple Mac OS X 10.3.2
  • Apple Mac OS X 10.3.3
  • Apple Mac OS X 10.3.4
  • Apple Mac OS X 10.3.5
  • Apple Mac OS X 10.3.6
  • Apple Mac OS X 10.3.7
  • Apple Mac OS X 10.3.8
  • Apple Mac OS X 10.3.9
  • Apple Mac OS X 10.4
  • Apple Mac OS X 10.4.1
  • Apple Mac OS X 10.4.10
  • Apple Mac OS X 10.4.11
  • Apple Mac OS X 10.4.2
  • Apple Mac OS X 10.4.3
  • Apple Mac OS X 10.4.4
  • Apple Mac OS X 10.4.5
  • Apple Mac OS X 10.4.6
  • Apple Mac OS X Server 10.3
  • Apple Mac OS X Server 10.3.1
  • Apple Mac OS X Server 10.3.2
  • Apple Mac OS X Server 10.3.3
  • Apple Mac OS X Server 10.3.4
  • Apple Mac OS X Server 10.3.5
  • Apple Mac OS X Server 10.3.6
  • Apple Mac OS X Server 10.3.7
  • Apple Mac OS X Server 10.3.8
  • Apple Mac OS X Server 10.3.9
  • Apple Mac OS X Server 10.4
  • Apple Mac OS X Server 10.4.1
  • Apple Mac OS X Server 10.4.10
  • Apple Mac OS X Server 10.4.11
  • Apple Mac OS X Server 10.4.2
  • Apple Mac OS X Server 10.4.3
  • Apple Mac OS X Server 10.4.4
  • Apple Mac OS X Server 10.4.5
  • Apple Mac OS X Server 10.4.6

Reported:

Apr 19, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page