Ethereal ASN.1 dissector denial of service

ethereal-asn1-dissector-dos (26022) The risk level is classified as MediumMedium Risk

Description:

Ethereal is vulnerable to a denial of service. A remote attacker could exploit an unspecified vulnerability in the ASN.1 dissector using a malformed packet or trace file to cause Ethereal to crash.


Consequences:

Denial of Service

Remedy:

Upgrade to the latest stable version of Ethereal (0.99.0 or later), as listed in Ethereal Security Advisory enpa-sa-00023. See References.

For Red Hat Linux:
Refer to RHSA-2006:0420-8 for patch, upgrade, or suggested workaround information. See References.

For Debian GNU/Linux:
Refer to DSA-1049-1 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux:
Refer to Gentoo Linux Security Announcement GLSA 2006-04-17 for patch, upgrade, or suggested workaround information. See References.

References:

  • Ethereal Security Advisory enpa-sa-00023: Multiple problems in Ethereal versions 0.8.5 to 0.10.14.
  • Ethereal Web site: Ethereal: Download.
  • Ethereal Web site: Ethereal: A Network Protocol Analyzer.
  • ASA-2006-128: ethereal security update (RHSA-2006-0420)
  • BID-17682: Ethereal Multiple Protocol Dissector Vulnerabilities In Versions Prior To 0.99.0
  • CVE-2006-1939: Multiple unspecified vulnerabilities in Ethereal 0.9.x up to 0.10.14 allow remote attackers to cause a denial of service (crash from null dereference) via (1) an invalid display filter, or the (2) GSM SMS, (3) ASN.1-based, (4) DCERPC NT, (5) PER, (6) RPC, (7) DCERPC, and (8) ASN.1 dissectors.
  • DSA-1049: ethereal -- several vulnerabilities
  • GLSA-200604-17: Ethereal: Multiple vulnerabilities in protocol dissectors
  • MDKSA-2006:077: Updated ethereal packages fix numerous vulnerabilities
  • RHSA-2006-0420: ethereal security update
  • SA19769: Ethereal Multiple Protocol Dissector Vulnerabilities
  • SA20944: Avaya Products Ethereal Vulnerabilities
  • SECTRACK ID: 1015985: Ethereal Bugs in Multipe Dissectors Lets Remote Users Execute Arbitrary Code and Remote Deny Service
  • SUSE-SR:2006:010: SUSE Security Summary Report

Platforms Affected:

  • Debian Debian Linux 3.0
  • Debian Debian Linux 3.1
  • Ethereal Ethereal 0.9.8 - 0.10.14
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 2006
  • MandrakeSoft Mandrake Linux 2006 X86_64
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 4 WS
  • RedHat Enterprise Linux 4 ES
  • RedHat Enterprise Linux 4 AS
  • RedHat Enterprise Linux 4 Desktop
  • RedHat Linux Advanced Workstation 2.1 Itanium

Reported:

Apr 24, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page