phpwcms act_formmailer.php and mail_file_form.php header injection

phpwcms-formmailer-fileform-header-injection (26130) The risk level is classified as LowLow Risk

Description:

phpwcms is vulnerable to header injection, caused by improper validation of the HTTP REFERER header by the act_formmailer.php and mail_file_form.php scripts. A remote attacker could exploit this vulnerability to use an affected system to send arbitrary email and spam messages.


Consequences:

Bypass Security

Remedy:

Apply the patch for this vulnerability, available from the phpwcms Web site. See References.

References:

  • phpwcms Forum, Fri Apr 21, 2006 16:11: Security Alert 1.2.6 CVS.
  • phpwcms Web site: phpwcms.
  • CVE-2006-7020: CRLF injection vulnerability in (1) include/inc_act/act_formmailer.php and possibly (2) sample_ext_php/mail_file_form.php in phpwcms 1.2.5-DEV and earlier, and 1.1 before RC4, allows remote attackers to modify HTTP headers and send spam e-mail via a spoofed HTTP Referer (HTTP_REFERER).
  • OSVDB ID: 25137: phpwcms act_formmailer.php HTTP_REFERER Email Header Injection
  • SA19866: phpwcms Multiple Vulnerabilities

Platforms Affected:

  • phpwcms phpwcms 1.1 RC4
  • phpwcms phpwcms 1.2.5-DEV

Reported:

Apr 21, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page