Pinnacle Cart setbackurl cross-site scripting

pinnaclecart-setbackurl-xss (26162) The risk level is classified as MediumMedium Risk

Description:

Pinnacle Cart is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by the index.php script. A remote attacker could exploit this vulnerability using the 'setbackurl' parameter to execute script in a victim's Web browser within the security context of the hosting Web site, allowing the attacker to steal the victim's cookie-based authentication credentials.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of Pinnacle Cart, available from the Pinnacle Cart Web site. See References.

References:

  • Pinnacle Cart Web site: PHP Shopping Cart Software - Online Ecommerce - PinnacleCart.com.
  • UNSECURED SYSTEMS 30 april 2006: Pinnacle Cart XSS.
  • BID-17794: Pinnacle Cart Index.PHP Cross-Site Scripting Vulnerability
  • CVE-2006-2163: Cross-site scripting (XSS) vulnerability in index.php in Pinnacle Cart 3.33 and earlier allows remote attackers to inject arbitrary web script or HTML via the setbackurl parameter.
  • OSVDB ID: 25150: Pinnacle Cart index.php setbackurl Parameter XSS
  • SA19878: Pinnacle Cart "setbackurl" Cross-Site Scripting Vulnerability

Platforms Affected:

  • Pinnacle Cart Pinnacle Cart 3.33 and prior

Reported:

Apr 30, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page