Avactis Shopping Cart multiple scripts cross-site scripting

avactis-multiple-scripts-xss (26179) The risk level is classified as MediumMedium Risk

Description:

Avactis Shopping Cart is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by multiple scripts. A remote attacker could exploit this vulnerability using the 'category_id' parameter in the store.php, store_special_offers.php scripts or using the 'prod_id' parameter in the product_info.php script to execute script in a victim's Web browser within the security context of the hosting Web site, allowing the attacker to steal the victim's cookie-based authentication credentials.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of Avactis Shopping Cart (version 0.1.3 or later), available from the Avactis Shopping Cart Web site. See References.

References:

  • Avactis Shopping Cart Web site: Avactis Ecommerce Shopping Cart Software.
  • UNSECURED SYSTEMS 1 may 2006: Avactis Shopping Cart vuln. .
  • CVE-2006-2165: Multiple cross-site scripting (XSS) vulnerabilities in Avactis Shopping Cart 0.1.2 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) category_id parameter in (a) store_special_offers.php and (b) store.php and (2) prod_id parameter in (c) product_info.php. NOTE: this issue might be resultant from SQL injection.
  • OSVDB ID: 25641: Avactis Shopping Cart store_special_offers.php category_id Parameter XSS
  • OSVDB ID: 25642: Avactis Shopping Cart product_info.php prod_id Parameter XSS
  • OSVDB ID: 25643: Avactis Shopping Cart store.php category_id Parameter XSS

Platforms Affected:

  • Pentasoft Corp Avactis Shopping Cart 0.1.2 and prior

Reported:

May 01, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page