Newsadmin readarticle.php SQL injection

newsadmin-readarticle-sql-injection (26247) The risk level is classified as MediumMedium Risk

Description:

Newsadmin is vulnerable to SQL injection. A remote attacker could send specially-crafted SQL statements to the readarticle.php script using the 'nid' parameter, which could allow the attacker to add, modify, or delete information in the back-end database.


Consequences:

Data Manipulation

Remedy:

No remedy available as of September 1, 2014.

References:

  • eVuln Advisory EV0133: Newsadmin SQL Injection Vulnerability.
  • Newsadmin Web site: Newsadmin.
  • BID-17854: Newsadmin Readarticle.PHP SQL Injection Vulnerability
  • CVE-2006-2239: SQL injection vulnerability in readarticle.php in Newsadmin 1.1 allows remote attackers to execute arbitrary SQL commands via the nid parameter.
  • OSVDB ID: 25276: Newsadmin readarticle.php nid Parameter SQL Injection
  • SA19972: Newsadmin "nid" SQL Injection Vulnerability

Platforms Affected:

  • Newsadmin Newsadmin 1.1

Reported:

May 04, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page