AWStats migrate parameter command execution

awstats-migrate-command-execution (26287) The risk level is classified as HighHigh Risk

Description:

AWStats could allow a remote attacker to execute arbitrary commands on the system. If the "AllowToUpdateStatsFromBrowser" option is enabled, a remote attacker could send a specially-crafted HTTP request to the awstats.pl script containing a pipe character followed by arbitrary shell commands in the "migrate" parameter which would be executed with the privileges of the Web server process.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of AWStats (6.6 or later), available from the AWStats Web site. See References.

For Ubuntu Linux:
Refer to USN-285-1 for patch, upgrade, or suggested workaround information. See References.

For Debian GNU/Linux:
Refer to DSA-1058-1 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux:
Refer to Gentoo Linux Security Announcement GLSA 2006-06-06 for patch, upgrade, or suggested workaround information. See References.

For SUSE Linux:
Refer to SUSE-SA:2006:033 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • AWStats Web site: AWStats security announcements.
  • OS Reviews 2006-05-03: AWStats: Flexible but Insecure.
  • BID-17844: AWStats Remote Arbitrary Command Execution Vulnerability
  • CVE-2006-2237: The web interface for AWStats 6.4 and 6.5, when statistics updates are enabled, allows remote attackers to execute arbitrary code via shell metacharacters in the migrate parameter.
  • DSA-1058: awstats -- missing input sanitising
  • GLSA-200606-06: AWStats: Remote execution of arbitrary code
  • OSVDB ID: 25284: AWStats migrate Variable Arbitrary Command Execution
  • SA19969: AWStats "migrate" Shell Command Injection Vulnerability
  • SUSE-SA:2006:033: awstats remote code execution
  • USN-285-1: AWStats vulnerability

Platforms Affected:

  • AWStats AWStats 6.5 and prior
  • Canonical Ubuntu 5.04
  • Canonical Ubuntu 5.10
  • Debian Debian Linux 3.1
  • Gentoo Linux
  • Novell UnitedLinux 1.0
  • SUSE SuSE Linux 10.0
  • SUSE SuSE Linux 10.1
  • SUSE SuSE Linux 9.1
  • SUSE SuSE Linux 9.2
  • SUSE SuSE Linux 9.3

Reported:

May 03, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page