SaphpLesson search.php and misc.php SQL injection

saphplesson-search-misc-sql-injection (26293) The risk level is classified as MediumMedium Risk

Description:

SaphpLesson is vulnerable to SQL injection. A remote attacker could send specially-crafted SQL statements to the search.php script using the 'find' parameter or to the misc.php script using the 'lid' or 'rate' parameter, which could allow the attacker to view, add, modify, or delete information in the back-end database.


Consequences:

Data Manipulation

Remedy:

No remedy available as of July 1, 2014.

References:

  • BugTraq Mailing List, Thu May 04 2006 - 16:09:41 CDT: SaPHPLesson 3.0 Multbugs.
  • BID-17848: SAPHP Lesson Multiple SQL Injection Vulnerabilities
  • CVE-2006-2279: Multiple SQL injection vulnerabilities in SaphpLesson 3.0 allow remote attackers to execute arbitrary SQL commands via (1) the Find parameter in (a) search.php, and the (2) LID and (3) Rate parameters in (b) misc.php.
  • OSVDB ID: 25362: SaphpLesson search.php Find Parameter SQL Injection
  • OSVDB ID: 25363: SaphpLesson misc.php Multiple Parameter SQL Injection
  • SA20034: SaphpLesson SQL Injection Vulnerabilities
  • VUPEN/ADV-2006-1708: SaphpLesson Multiple SQL Injection and Full Path Disclosure Vulnerabilities

Platforms Affected:

  • Arabless SaphpLesson 3.0

Reported:

May 04, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page