VP-ASP Shopping Cart shopcurrency.asp SQL injection

vpaspshopcart-shopcurrency-sql-injection (26337) The risk level is classified as MediumMedium Risk

Description:

VP-ASP Shopping Cart is vulnerable to SQL injection. A remote attacker could send specially-crafted SQL statements to the shopcurrency.asp file using the cid parameter, which could allow the attacker to add, modify, or delete information in the back-end database.


Consequences:

Data Manipulation

Remedy:

Upgrade to the current version of VP-ASP Shopping Cart (6.08 or later) available from the VP-ASP Web site. See References.

References:

  • VP-ASP Web site: VP-ASP 6.00 Patches.
  • VP-ASP Web site: VP-ASP Shopping Cart.
  • BID-17882: VP-ASP Shopping Cart Shopcurrency.ASP SQL Injection Vulnerability
  • CVE-2006-2263: SQL injection vulnerability in shopcurrency.asp in VP-ASP 6.00 allows remote attackers to execute arbitrary SQL commands via the cid parameter.
  • OSVDB ID: 25449: VP-ASP Shopping Cart shopcurrency.asp cid Parameter SQL Injection
  • SA20004: VP-ASP Shopping Cart "cid" SQL Injection Vulnerability

Platforms Affected:

  • Rocksalt International VP-ASP 6.00

Reported:

May 06, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page