Ideal BB cross-site scripting

ldealbb-xss (26355) The risk level is classified as MediumMedium Risk

Description:

Ideal BB is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability to execute script in a victim's Web browser within the security context of the hosting Web site, allowing the attacker to steal the victim's cookie-based authentication credentials.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of Ideal BB (1.5.4b or later), available from the Ideal BB Web site. See References.

References:

  • Full-Disclosure Mailing List, Sun May 07 2006 - 23:59:00 CDT: Multiple Vulnerabilities In IdealBB ASP Bulletin Board.
  • Ideal BB Web site: Ideal Science: Bulletin Board Software.
  • BID-17920: IdealBB Multiple Input Validation Vulnerabilities
  • CVE-2006-2321: Multiple cross-site scripting (XSS) vulnerabilities in Ideal Science Ideal BB 1.5.4a and earlier allow remote attackers to inject arbitrary web script or HTML via unknown vectors. NOTE: due to lack of details from the researcher, it is not clear whether this overlaps CVE-2004-2207.
  • OSVDB ID: 25458: IdealBB Multiple Unspecified XSS
  • SA20035: IdealBB Multiple Vulnerabilities

Platforms Affected:

  • Ideal Science Ideal BB 1.5.4a and prior

Reported:

May 08, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page