phpMyAdmin theme parameter cross-site scripting
|phpmyadmin-theme-parameter-xss (26444)||Medium Risk|
phpMyAdmin is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability using the 'theme' parameter to execute script in a victim's Web browser within the security context of the hosting Web site, allowing the attacker to steal the victim's cookie-based authentication credentials.
Upgrade to the current version of phpMyAdmin (220.127.116.11 or later) available from the phpMyAdmin Project Web site. See References.
- phpMyAdmin security announcement PMASA-2006-2: XSS vulnerabilities .
- The phpMyAdmin Project Web site: phpMyAdmin - 18.104.22.168.
- BID-17973: phpMyAdmin Index.PHP Multiple Cross-Site Scripting Vulnerabilities
- CVE-2006-2417: Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.8.0.x before 22.214.171.124 allows remote attackers to inject arbitrary web script or HTML via the theme parameter in unknown scripts. NOTE: the lang parameter is already covered by CVE-2006-2031.
- SA20113: phpMyAdmin "theme" and "db" Cross-Site Scripting Vulnerabilities
- SUSE-SR:2006:013: SUSE Security Summary Report
- phpMyAdmin phpMyAdmin 2.8.0.x - 126.96.36.199
May 12, 2006
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this