phpCOIN email address information disclosure

phpcoin-emailaddress-information-disclosure (26499) The risk level is classified as LowLow Risk

Description:

phpCOIN could allow a remote attacker to obtain sensitive information. phpCOIN does not verify that a new email address is unique in the system. A remote attacker could exploit this vulnerability by adding a contact or changing an email address to a known email address to view messages that belong to that user.


Consequences:

Obtain Information

Remedy:

Upgrade to the current CVS for phpCOIN available from the phpCOIN Web site. See References.

References:

  • phpCOIN Forums 2006-05-11: Information Disclosure Issue.
  • phpCOIN Web site: Welcome to phpCOIN.
  • BID-17959: phpCOIN Email Address Information Disclosure Vulnerability
  • CVE-2006-2422: phpCOIN 1.2.3 and earlier stores messages based upon e-mail addresses, which allows remote authenticated users to read messages for other users by adding the sender's e-mail address as an additional contact.
  • OSVDB ID: 25495: phpCOIN E-Mail Address Arbitrary Message Disclosure
  • SA20088: phpCOIN E-Mail Address Disclosure of Arbitrary Messages

Platforms Affected:

  • phpCOIN phpCOIN

Reported:

May 11, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page