Raydium raydium_log() and raydium_console_line_add() buffer overflow

raydium-raydiumlog-bo (26510) The risk level is classified as HighHigh Risk

Description:

Raydium is vulnerable to a stack-based buffer overflow, caused by improper bounds checking by the raydium_log() and the raydium_console_line_add() functions. By sending a specially-crafted join request, a remote attacker could overflow a buffer and execute arbitrary code on the system.


Consequences:

Gain Access

Remedy:

Upgrade to the latest SVN revision (310 or later), available from the Raydium Web site. See references.

References:

  • Full-Disclosure Mailing List, Fri May 12 2006 - 16:25:33 CDT: Multiple vulnerabilities in Raydium rev 309.
  • Raydium Web site: Raydium 3D Game Engine - OpenSource - GPL.
  • BID-17986: Raydium Multiple Remote Buffer Overflow and Denial Of Service Vulnerabilities
  • CVE-2006-2408: Multiple buffer overflows in Raydium before SVN revision 310 allow remote attackers to execute arbitrary code via a large packet when logged via (1) the raydium_log function in log.c or (2) the raydium_console_line_add function in console.c, possibly from a long player name.
  • OSVDB ID: 25483: Raydium Multiple Logging Function Remote Overflow
  • SA20097: Raydium Multiple Vulnerabilities

Platforms Affected:

  • Raydium.org Raydium 2005-09-21
  • Raydium.org Raydium SVN revision 309

Reported:

May 12, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page