phpwcms template files cross-site scripting

phpwcms-template-files-xss (26638) The risk level is classified as MediumMedium Risk

Description:

phpwcms is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by multiple template files. If register_globals is enabled, a remote attacker could exploit this vulnerability to execute script in a victim's Web browser within the security context of the hosting Web site, allowing the attacker to steal the victim's cookie-based authentication credentials.


Consequences:

Gain Access

Remedy:

No remedy available as of May 2007.

References:

  • BugTraq Mailing List, Sun May 21 2006 - 18:11:59 CDT: [KAPDA::#43] - phpwcms multiple vulnerabilities.
  • phpwcms Web site: phpwcms.
  • BID-18063: PHPWCMS CNT6.INC.PHP Cross-Site Scripting Vulnerability
  • CVE-2006-2518: Cross-site scripting (XSS) vulnerability in phpwcms 1.2.5-DEV allows remote attackers to inject arbitrary web script or HTML via the BL[be_cnt_plainhtml] parameter to include/inc_tmpl/content/cnt6.inc.php.
  • OSVDB ID: 25754: phpwcms cnt6.inc.php BL[be_cnt_plainhtml] Parameter XSS
  • SA20239: phpwcms Cross-Site Scripting and Local File Inclusion
  • VUPEN/ADV-2006-1934: phpwcms Multiple Local File Inclusion and Cross Site Scripting Vulnerabilities

Platforms Affected:

  • phpwcms phpwcms 1.2.5 DEV

Reported:

May 21, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page