xine-lib xineplug_inp_http.so buffer overflow

xinelib-xinepluginphttp-bo (26972) The risk level is classified as LowLow Risk

Description:

xine-lib is vulnerable to a heap-based buffer overflow, caused by improper bounds checking of the xineplug_inp_http.so plugin. By sending an overly long reply from the HTTP server, a remote attacker could overflow a buffer and cause the application to crash.

Note: gxine is vulnerable to this exploit. Other products using xine-lib version 1.1.1 could also be vulnerable.


Consequences:

Denial of Service

Remedy:

For xine-lib:
Upgrade to the latest version of xine-lib (1.1.2 or later), available from the xine Web site. See References.

For Debian GNU/Linux:
Refer to DSA-1105-1 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux:
Refer to Gentoo Linux Security Announcement GLSA 200609-08 for patch, upgrade, or suggested workaround information. See References.

References:

  • xine Web site: xine - A Free Video Player - News - xine-lib 1.1.2.
  • xine Web site: xine - A Free Video Player.
  • BID-18187: Xine-Lib HTTP Response Buffer Overflow Vulnerability
  • CVE-2006-2802: Buffer overflow in the HTTP Plugin (xineplug_inp_http.so) for xine-lib 1.1.1 allows remote attackers to cause a denial of service (application crash) via a long reply from an HTTP server, as demonstrated using gxine 0.5.6.
  • DSA-1105: xine-lib -- buffer overflow
  • GLSA-200609-08: xine-lib: Buffer overflows
  • MDKSA-2006:108: Updated xine-lib packages fix buffer overflow vulnerabilities
  • MDKSA-2006:173: Updated ffmpeg packages fix buffer overflow vulnerabilities
  • MDKSA-2006:175: Updated mplayer packages fix buffer overflow vulnerabilities
  • MDKSA-2006:176: Updated xine-lib packages fix buffer overflow vulnerabilities
  • OSVDB ID: 25936: xine-lib xineplug_inp_http.so HTTP Response Remote Overflow
  • SA20369: xine-lib HTTP Response Heap Corruption Weakness
  • SUSE-SR:2006:014: SUSE Security Summary Report
  • USN-295-1: xine-lib vulnerability

Platforms Affected:

  • Canonical Ubuntu 5.04
  • Canonical Ubuntu 5.10
  • Canonical Ubuntu 6.06 LTS
  • Debian Debian Linux 3.0
  • Debian Debian Linux 3.1
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 2006
  • MandrakeSoft Mandrake Linux 2006 X86_64
  • MandrakeSoft Mandrake Linux 2007
  • MandrakeSoft Mandrake Linux 2007 X86_64
  • MandrakeSoft Mandrake Linux LE2005 X86_64
  • MandrakeSoft Mandrake Linux LE2005
  • MandrakeSoft Mandrake Linux Corporate Server 3.0 X86_64
  • MandrakeSoft Mandrake Linux Corporate Server 3.0
  • MandrakeSoft Mandrake Linux Corporate Server 4.0
  • MandrakeSoft Mandrake Linux Corporate Server 4.0 X86_64
  • Xine xine-lib 1.1.1

Reported:

May 30, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page