Mutt IMAP namespace buffer overflow

mutt-imap-namespace-bo (27428) The risk level is classified as HighHigh Risk

Description:

Mutt is vulnerable to a stack-based buffer overflow, caused by improper bounds checking by the browse_get_namespace() function in browse.c. If a remote attacker could convince the victim to connect to a malicious IMAP server, then the attacker could send an overly long namespace from the IMAP server to overflow a buffer and execute arbitrary code on the system or cause the application to crash.


Consequences:

Gain Access

Remedy:

Apply the appropriate patch for this vulnerability, available from the Mutt CVS Repository. See References.

For Gentoo Linux:
Refer to Gentoo Linux Security Announcement GLSA 2006-06-27 for patch, upgrade, or suggested workaround information. See References.

For Debian GNU/Linux:
Refer to DSA-1108-1 for patch, upgrade, or suggested workaround information. See References.

For Red Hat Linux:
Refer to RHSA-2006:0577-3 for patch, upgrade, or suggested workaround information. See References.

For OpenPKG:
Refer to OpenPKG Security Advisory OpenPKG-SA-2006.013 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • Mutt CVS Repository: FAUmachine Repository - log - FAUmachine: mutt/imap/browse.c.
  • Mutt FAUmachine Repository: FAUmachine Repository - markup - FAUmachine: mutt/imap/browse.c.
  • Mutt Web site: The Mutt E-Mail Client.
  • ASA-2006-142: mutt security update (RHSA-2006-0577)
  • BID-18642: Mutt BROWSE_GET_NAMESPACE IMAP Namespace Processing Remote Buffer Overflow Vulnerability
  • CVE-2006-3242: Stack-based buffer overflow in the browse_get_namespace function in imap/browse.c of Mutt 1.4.2.1 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via long namespaces received from the IMAP server.
  • DSA-1108: mutt -- buffer overflow
  • GLSA-200606-27: Mutt: Buffer overflow
  • MDKSA-2006:115: Updated mutt packages fix buffer overflow vulnerability
  • OpenPKG-SA-2006.013: Mutt
  • RHSA-2006-0577: mutt security update
  • SA20810: Mutt IMAP Namespace Buffer Overflow Vulnerability
  • SECTRACK ID: 1016482: Mutt Buffer Overflow in browse_get_namespace() Lets Remote Servers Execute Arbitrary Code
  • SUSE-SR:2006:016: SUSE Security Summary Report
  • USN-307-1: mutt vulnerability

Platforms Affected:

  • Canonical Ubuntu 5.04
  • Canonical Ubuntu 5.10
  • Canonical Ubuntu 6.06 LTS
  • Debian Debian Linux 3.1
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 2006 X86_64
  • MandrakeSoft Mandrake Linux 2006
  • MandrakeSoft Mandrake Linux LE2005
  • MandrakeSoft Mandrake Linux LE2005 X86_64
  • MandrakeSoft Mandrake Linux Corporate Server 3.0 X86_64
  • MandrakeSoft Mandrake Linux Corporate Server 3.0
  • Michael R. Elkins and Jeremy Blosser Mutt 1.4.2.1
  • OpenPKG OpenPKG 2-STABLE
  • OpenPKG OpenPKG 2.5
  • OpenPKG OpenPKG CURRENT
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 4 ES
  • RedHat Enterprise Linux 4 Desktop
  • RedHat Enterprise Linux 4 AS
  • RedHat Enterprise Linux 4 WS
  • RedHat Linux Advanced Workstation 2.1 Itanium

Reported:

Jun 19, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page