Mozilla Firefox, Thunderbird, and SeaMonkey XPCOM event memory corruption

mozilla-xpcom-memory-corruption (27982) The risk level is classified as HighHigh Risk

Description:

Mozilla Firefox, Thunderbird and SeaMonkey could allow a remote attacker to execute arbitrary code on the system, caused by a memory corruption error that could occur when handling simultaneous XPCOM events that would result in the use of a deleted timer object. A remote attacker could exploit this vulnerability by persuading a victim to visit a malicious Web page.

*CVSS:

Base Score: 7
  Access Vector: Remote
  Access Complexity: Low
  Authentication: Not Required
  Confidentiality Impact: Partial
  Integrity Impact: Partial
  Availability Impact: Partial
 
Temporal Score: 5.2
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Refer to Mozilla Foundation Security Advisory 2006-46 for upgrade or suggested workaround information. See References.

For Red Hat Linux 2.1(Seamonkey):
Refer to RHSA-2006:0594-9 for patch, upgrade, or suggested workaround information. See References.

For Red Hat Linux 3 (Seamonkey):
Refer to RHSA-2006:0608-6 for patch, upgrade, or suggested workaround information. See References.

For Red Hat Linux 4 (Seamonkey):
Refer to RHSA-2006:0609-9 for patch, upgrade, or suggested workaround information. See References.

For Red Hat Linux 4 (Thunderbird):
Refer to RHSA-2006:0611-3 for patch, upgrade, or suggested workaround information. See References.

For Red Hat Linux 4 (Firefox):
Refer to RHSA-2006:0610-4 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux (Thunderbird):
Refer to Gentoo Linux Security Announcement GLSA 200608-04 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux (Firefox):
Refer to Gentoo Linux Security Announcement GLSA 200608-03 for patch, upgrade, or suggested workaround information. See References.

For Gentoo Linux (Seamonkey):
Refer to Gentoo Linux Security Announcement GLSA 200608-02 for patch, upgrade, or suggested workaround information. See References.

For SUSE Linux:
Refer to SUSE-SA:2006:048 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • MFSA 2006-46: Memory corruption with simultaneous events.
  • US-CERT Technical Cyber Security Alert TA06-208A: Mozilla Products Contain Multiple Vulnerabilities.
  • ASA-2006-149: seamonkey security update (RHSA-2006-0608)
  • ASA-2006-151: firefox seamonkey and thunderbird security update (RHSA-2006-0609 RHSA-2006-0610 and RHSA-2006-0611)
  • ASA-2006-208: seamonkey security update (was mozilla) (RHSA-2006-0594)
  • ASA-2006-259: HP-UX Firefox Vulnerabilities
  • ASA-2007-097: HP-UX Running Firefox Remote Unauthorized Access or Elevation of Privileges or Denial of Service (DoS) (HPSBUX02153)
  • ASA-2007-135: HP-UX Running Thunderbird Remote Unauthorized Access or Elevation of Privileges or Denial of Service (HPSBUX02156)
  • BID-19181: Mozilla Multiple Products Remote Vulnerabilities
  • BID-19197: Mozilla Foundation Products XPCOM Memory Corruption Vulnerability
  • CVE-2006-3113: Mozilla Firefox 1.5 before 1.5.0.5, Thunderbird before 1.5.0.5, and SeaMonkey before 1.0.3 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via simultaneous XPCOM events, which causes a timer object to be deleted in a way that triggers memory corruption.
  • GLSA-200507-24: Mozilla Suite: Multiple vulnerabilities
  • GLSA-200608-02: Mozilla SeaMonkey: Multiple vulnerabilities
  • GLSA-200608-03: Mozilla Firefox: Multiple vulnerabilities
  • GLSA-200608-04: Mozilla Thunderbird: Multiple vulnerabilities
  • MDKSA-2006:143: Updated Firefox packages fix multiple vulnerabilities
  • MDKSA-2006:143-1: Updated Firefox packages fix multiple vulnerabilities
  • MDKSA-2006:145: Updated Firefox packages fix multiple vulnerabilities
  • MDKSA-2006:146: Updated Thunderbird packages fix multiple vulnerabilities
  • RHSA-2006-0594: seamonkey security update (was mozilla)
  • RHSA-2006-0608: seamonkey security update
  • RHSA-2006-0609: seamonkey security update
  • RHSA-2006-0610: firefox security update
  • RHSA-2006-0611: thunderbird security update
  • SA19873: Mozilla Firefox Multiple Vulnerabilities
  • SA21228: Mozilla Thunderbird Multiple Vulnerabilities
  • SA21229: Mozilla SeaMonkey Multiple Vulnerabilities
  • SECTRACK ID: 1016586: Mozilla Firefox Multiple Bugs Let Remote Users Execute Arbitrary Code
  • SECTRACK ID: 1016587: Mozilla Seamonkey Multiple Bugs Let Remote Users Execute Arbitrary Code
  • SECTRACK ID: 1016588: Mozilla Thunderbird Multiple Bugs Let Remote Users Execute Arbitrary Code
  • SUSE-SA:2006:048: Mozilla Firefox Thunderbird and Seamonkey security problems
  • US-CERT VU#239124: Mozilla fails to properly handle simultaneous XPCOM events
  • USN-327-1: Firefox vulnerabilities
  • USN-327-2: Firefox regression
  • USN-329-1: Thunderbird vulnerabilities
  • USN-350-1: Thunderbird vulnerabilities
  • USN-354-1: Firefox vulnerabilities

Platforms Affected:

  • Canonical Ubuntu 5.10
  • Canonical Ubuntu 6.06 LTS
  • Gentoo Linux
  • MandrakeSoft Mandrake Linux 2006 X86_64
  • MandrakeSoft Mandrake Linux 2006
  • MandrakeSoft Mandrake Linux Corporate Server 3.0
  • MandrakeSoft Mandrake Linux Corporate Server 3.0 X86_64
  • Mozilla Firefox 1.5
  • Mozilla Firefox 1.5.0.1
  • Mozilla Firefox 1.5.0.2
  • Mozilla Firefox 1.5.0.3
  • Mozilla Firefox 1.5.0.4
  • Mozilla SeaMonkey 1.0 Dev
  • Mozilla SeaMonkey 1.0
  • Mozilla SeaMonkey 1.0.1
  • Mozilla SeaMonkey 1.0.2
  • Mozilla Thunderbird 1.5
  • Mozilla Thunderbird 1.5.0.1
  • Mozilla Thunderbird 1.5.0.2
  • Mozilla Thunderbird 1.5.0.3
  • Mozilla Thunderbird 1.5.0.4
  • Novell Linux Desktop 9
  • Novell SLE SDK 10
  • RedHat Enterprise Linux 2.1 WS
  • RedHat Enterprise Linux 2.1 ES
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 4 AS
  • RedHat Enterprise Linux 4 WS
  • RedHat Enterprise Linux 4 Desktop
  • RedHat Enterprise Linux 4 ES
  • RedHat Linux Advanced Workstation 2.1 Itanium
  • SUSE SuSE Linux 10.0
  • SUSE SuSE Linux 10.1
  • SUSE SuSE Linux 9.2
  • SUSE SuSE Linux 9.3
  • SuSE SuSE SLES 10

Reported:

Jul 26, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page

* According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall IBM be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

About IBM Internet Security Systems

IBM Internet Security Systems is a trusted security advisor to thousands of the world's leading businesses and governments, helping to provide pre-emptive protection for networks, desktops and servers. The IBM Proventia? integrated security platform is designed to automatically protect against both known and unknown threats, helping to keep networks up and running and shield customers from online attacks before they impact business assets. IBM Internet Security Systems products and services are based on the proactive security intelligence of its X-Force? research and development team ? an unequivocal world authority in vulnerability and threat research. The IBM Internet Security Systems product line is also complemented by comprehensive Managed Security Services and Professional Security Services. For more information, visit the IBM Internet Security Systems Web site at www.iss.net or call 800-776-2362.