PhpMyAdmin multiple parameter cross-site scripting
|phpmyadmin-multiple-parameter-xss (30310)||Medium Risk|
phpMyAdmin is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by multiple scripts. A remote attacker could exploit this vulnerability using the db, newname, query_history_latest, query_history_latest_db, querydisplay_tab or the pos parameters in a specially-crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.
Note: The following scripts are reported to be vulnerable:
Upgrade to the latest version of phpMyAdmin (18.104.22.168 or later), available from the phpMyAdmin Web site. See References.
For Debian GNU/Linux (phpmyadmin):
Refer to DSA-1370-1 for patch, upgrade, or suggested workaround information. See References.
For other distributions:
Contact your vendor for upgrade or patch information.
- BugTraq Mailing List, Thu Nov 16 2006 - 10:32:27 CST : PhpMyAdmin all version [multiples vulnerability].
- phpMyAdmin Web site: phpMyAdmin | MySQL Database Administration Tool | www.phpmyadmin.net.
- BID-21137: phpMyAdmin Multiple Input Validation Vulnerabilities
- CVE-2006-6942: Multiple cross-site scripting (XSS) vulnerabilities in PhpMyAdmin before 22.214.171.124 allow remote attackers to inject arbitrary HTML or web script via (1) a comment for a table name, as exploited through (a) db_operations.php, (2) the db parameter to (b) db_create.php, (3) the newname parameter to db_operations.php, the (4) query_history_latest, (5) query_history_latest_db, and (6) querydisplay_tab parameters to (c) querywindow.php, and (7) the pos parameter to (d) sql.php.
- DSA-1370: phpmyadmin -- several vulnerabilities
- GLSA-200903-32: phpMyAdmin: Multiple vulnerabilities
- Debian Debian Linux 3.1
- Debian Debian Linux 4.0
- Gentoo Linux
- phpMyAdmin phpMyAdmin
Nov 16, 2006
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this
* According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall IBM be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.