Odysseus Blog blog.php cross-site scripting

odysseusblog-blog-xss (30333) The risk level is classified as MediumMedium Risk


Odysseus Blog is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by the blog.php script. A remote attacker could exploit this vulnerability using the page parameter in a specially-crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.


Base Score: 2.8
  Access Vector: Remote
  Access Complexity: High
  Authentication: Not Required
  Confidentiality Impact: Partial
  Integrity Impact: None
  Availability Impact: None
Temporal Score: 2.7
  Exploitability: High
  Remediation Level: Unavailable
  Report Confidence: Uncorroborated


Gain Access


Upgrade to the latest version of Odysseus Blog (2.0.0 or later), available from the Odysseus Blog Web site. See References.


Platforms Affected:

  • Odysseus Blog Odysseus Blog 1.0.0 and prior


Nov 16, 2006

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page