Adobe Acrobat Reader Plugin MSVCRT.free() code execution

adobe-acrobat-msvcrt-code-execution (31272) The risk level is classified as HighHigh Risk

Description:

The Adobe Acrobat Reader Plugin could allow a remote attacker to execute arbitrary code on the system, caused by a double free memory corruption vulnerability in the MSVCRT.free() function. A remote attacker could exploit this vulnerability using a specially-crafted URL in a PDF document to cause a victim's browser to crash or possibly execute arbitrary code on the victim's system, if the attacker could persuade the victim to click the URL.

Note: This vulnerability only affects users running the Firefox browser.

*CVSS:

Base Score: 8
  Access Vector: Remote
  Access Complexity: High
  Authentication: Not Required
  Confidentiality Impact: Complete
  Integrity Impact: Complete
  Availability Impact: Complete
 
Temporal Score: 5.9
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of the Adobe Acrobat Reader Plugin (8.0.0 or later), available from the Adobe Acrobat Reader Plugin Web site. See References.

For Sun Solaris:
Refer to Sun Alert ID: 102847 for patch, upgrade, or suggested workaround information. See References.

For SUSE Linux (Acrobat Reader):
Refer to SUSE-SA:2007:011 for patch, upgrade, or suggested workaround information. See References.

For Red Hat Linux (Acrobat Reader):
Refer to RHSA-2007:0017 for patch, upgrade, or suggested workaround information. See References.

For Red Hat Linux (Acrobat Reader):
Refer to RHSA-2007:0021 for patch, upgrade, or suggested workaround information. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • Adobe Acrobat Reader Plugin Web site: Adobe - Reader.
  • Full-Disclosure Mailing List, Wed Jan 03 2007 - 11:22:49 CST: Adobe Acrobat Reader Plugin - Multiple Vulnerabilities.
  • Sun Alert ID: 102847: Multiple Security Vulnerabilities in Adobe Reader May Lead to Execution of Arbitrary Code.
  • ASA-2007-055: Adobe Acrobat Reader security update (RHSA-2007-0017)
  • ASA-2007-134: Multiple Security Vulnerabilities in Adobe Reader May Lead to Execution of Arbitrary Code (Sun 102847)
  • CVE-2007-0046: Double free vulnerability in the Adobe Acrobat Reader Plugin before 8.0.0, as used in Mozilla Firefox 1.5.0.7, allows remote attackers to execute arbitrary code by causing an error via a javascript: URI call to document.write in the (1) FDF, (2) XML, or (3) XFDF AJAX request parameters.
  • GLSA-200701-16: Adobe Acrobat Reader: Multiple vulnerabilities
  • RHSA-2007-0017: Critical: Adobe Acrobat Reader security update
  • RHSA-2007-0021: Critical: Adobe Acrobat Reader security update
  • SA24533: Sun Solaris Adobe Acrobat Multiple Vulnerabilities
  • SECTRACK ID: 1017469: Adobe Acrobat Reader Plugin Bugs Let Remote Users Deny Service, Conduct Cross-Site Scripting Attacks, and Execute Arbitrary Code
  • SUSE-SA:2007:011: Acrobat Reader 7.0.9 update

Platforms Affected:

  • Adobe Acrobat Reader Plugin 7.0.8
  • Gentoo Linux
  • Novell Linux Desktop 9
  • Novell OpenSUSE 10.2
  • RedHat RHEL Extras 3
  • RedHat RHEL Extras 4
  • Sun Solaris 10 SPARC
  • SuSE Linux Enterprise Server 8
  • SUSE SuSE Linux 10.0
  • SUSE SuSE Linux 10.1
  • SUSE SuSE Linux 9.3
  • SuSE SuSE SLED 10
  • SuSE SuSE SLES 9
  • Turbolinux Turbolinux FUJI

Reported:

Jan 03, 2007

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page

* According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall IBM be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

About IBM Security Systems

IBM Security Systems include an extensive portfolio of hardware, software solutions, professional and managed services offerings covering the spectrum of IT and business security risks: people and identity, data and information, application and process, network, server and endpoint and physical infrastructure, empowering clients to innovate and operate their businesses on the most secure infrastructure platforms. Through world-class solutions that address risk across the enterprise, IBM helps organizations build a strong security posture that helps reduce costs, improve service, and manage risk. IBM X-Force(R) Research and Development is one of the most renowned commercial security research and development groups in the world. For more information on how to address today's biggest risks, please visit us at ibm.com/security.