Netscape Enterprise Server contains a buffer overflow in its handling of Accept headers

netscape-accept-bo (3256) The risk level is classified as HighHigh Risk

Description:

Netscape Enterprise Server and FastTrack server, are vulnerable to a buffer overflow in the server's handling of Accept headers. By using a browsing client to send a specially-crafted URL, a remote attacker can execute arbitrary code on the system with privileges of the Web server process.


Consequences:

Gain Access

Remedy:

No workaround information is available for this vulnerability.

Install the latest version of Netscape Enterprise Server, available at the Netscape Downloads Web site. See References.

References:

Platforms Affected:

  • Apple Mac OS
  • Cisco IOS
  • Compaq Tru64
  • Data General DG/UX
  • HP HP-UX
  • IBM AIX
  • IBM OS2
  • Linux Kernel
  • Microsoft Windows 2000
  • Microsoft Windows 2003 Server
  • Microsoft Windows 95
  • Microsoft Windows 98
  • Microsoft Windows 98SE
  • Microsoft Windows Me
  • Microsoft Windows NT 4.0
  • Microsoft Windows XP
  • Netscape Enterprise Server
  • Novell NetWare
  • SCO SCO Unix
  • SGI IRIX
  • Sun Solaris
  • Wind River BSDOS

Reported:

Sep 13, 1999

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page