Dokeos courseLog.php SQL injection

dokeos-courselog-sql-injection (34483) The risk level is classified as MediumMedium Risk

Description:

Dokeos is vulnerable to SQL injection. A remote attacker with a valid teacher or student account could send specially-crafted SQL statements to the courseLog.php script using the scormcontopen parameter, which could allow the attacker to view, add, modify or delete information in the back-end database.

*CVSS:

Base Score: 4.2
  Access Vector: Remote
  Access Complexity: Low
  Authentication: Required
  Confidentiality Impact: Partial
  Integrity Impact: Partial
  Availability Impact: Partial
 
Temporal Score: 4
  Exploitability: High
  Remediation Level: Unavailable
  Report Confidence: Uncorroborated

Consequences:

Data Manipulation

Remedy:

No remedy available as of September 1, 2014.

References:

  • Dokeos Open Source e-Learning Web site: Dokeos.
  • BID-24136: Dokeos CourseLog.PHP SQL Injection Vulnerability
  • CVE-2007-2889: SQL injection vulnerability in tracking/courseLog.php in Dokeos 1.6.5 and earlier allows remote attackers to execute arbitrary SQL commands via the scormcontopen parameter.
  • OSVDB ID: 38061: Dokeos tracking/courseLog.php scormcontopen Parameter SQL Injection

Platforms Affected:

  • Dokeos Dokeos 1.6.5 and prior

Reported:

May 24, 2007

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page