phpMyAdmin db_create.php cross-site scripting

phpmyadmin-dbcreate-xss (38404) The risk level is classified as MediumMedium Risk

Description:

phpMyAdmin is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by the db_create.php script. A remote authenticated attacker could exploit this vulnerability using a Web browser that executes JavaScript code in the db parameter to inject malicious script into a Web page which would be executed in an authenticated victim's Web browser within the security context of the hosting Web site, once the page is viewed. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

*CVSS:

Base Score: 2.1
  Access Vector: Network
  Access Complexity: High
  Authentication: Single
  Confidentiality Impact: None
  Integrity Impact: Partial
  Availability Impact: None
 
Temporal Score: 1.8
  Exploitability: High
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of phpMyAdmin (2.11.2.1 or later), available from the phpMyAdmin Web site. See References.

References:

  • phpMyAdmin security announcement PMASA-2007-7: XSS vulnerabilities.
  • phpMyAdmin Web site: phpMyAdmin.
  • The DigiTrust Group Advisory #071108a: phpMyAdmin "db_create.php" persistent cross-site scripting vulnerability.
  • BID-26512: phpMyAdmin DB_Create.PHP Multiple Input Validation Vulnerabilities
  • CVE-2007-5977: Cross-site scripting (XSS) vulnerability in db_create.php in phpMyAdmin before 2.11.2.1 allows remote authenticated users with CREATE DATABASE privileges to inject arbitrary web script or HTML via a hex-encoded IMG element in the db parameter in a POST request, a different vulnerability than CVE-2006-6942.
  • GLSA-200903-32: phpMyAdmin: Multiple vulnerabilities
  • MDKSA-2007:229: Updated phpMyAdmin packages fix multiple vulnerabilities
  • OSVDB ID: 38714: phpMyAdmin db_create.php db Parameter XSS
  • SA27630: phpMyAdmin Database Name SQL Injection and Script Insertion

Platforms Affected:

  • Gentoo Linux
  • MandrakeSoft Mandrake Linux Corporate Server 4.0
  • MandrakeSoft Mandrake Linux Corporate Server 4.0 X86_64
  • phpMyAdmin phpMyAdmin prior to 2.11.2.1

Reported:

Nov 09, 2007

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page