OpenPegasus PAMBasicAuthenticator::PAMCallback() buffer overflow

openpegasus-pambasic-bo (39527) The risk level is classified as HighHigh Risk

Description:

OpenPegasus is vulnerable to a stack-based buffer overflow, caused by improper bounds checking by the PAMBasicAuthenticator::PAMCallback() function. By sending an overly long password, a remote attacker from within the local network could overflow a buffer and execute arbitrary code on the system with root privileges.

*CVSS:

Base Score: 8.3
  Access Vector: Adjacent Network
  Access Complexity: Low
  Authentication: None
  Confidentiality Impact: Complete
  Integrity Impact: Complete
  Availability Impact: Complete
 
Temporal Score: 6.1
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of OpenPegasus, available from the CVS Repository. See References.

For other distributions:
Apply the appropriate update for your system. See References.

References:

  • CVS Repository: OpenPegasus.
  • HP Security Bulletin HPSBMA02331 SSRT080000 rev.1: HP-UX running WBEM Services, Remote Execution of Arbitrary Code, Gain Extended Privileges.
  • IBM Subscription service Bulletin 4129: IBM Pegasus CIM Server for Director on AIX vulnerabilities.
  • OpenPegasus Web site: OpenPegasus.
  • ASA-2008-028: tog-pegasus security update (RHSA-2008-0002)
  • BID-27172: OpenPegasus WBEM CIM Management Server 'PAMBasicAuthenticatorUnix.cpp' Buffer Overflow Vulnerability
  • BID-27188: OpenPegasus Management Server PAM Authentication 'cimservera.cpp' Buffer Overflow Vulnerability
  • CVE-2008-0003: Stack-based buffer overflow in the PAMBasicAuthenticator::PAMCallback function in OpenPegasus CIM management server (tog-pegasus), when compiled to use PAM and without PEGASUS_USE_PAM_STANDALONE_PROC defined, might allow remote attackers to execute arbitrary code via unknown vectors, a different vulnerability than CVE-2007-5360.
  • OSVDB ID: 40082: OpenPegasus CIM Management Server (tog-pegasus) PAMBasicAuthenticator::PAMCallback Function Remote Overflow
  • RHSA-2008-0002: Critical: tog-pegasus security update
  • SA28358: OpenPegasus PAM Module Buffer Overflow Vulnerabilities
  • SA29056: IBM AIX Pegasus CIM Server for Director Vulnerabilities
  • SA29785: VMware ESX Server Multiple Security Updates
  • SA29986: HP-UX WBEM Services OpenPegasus PAM Module Buffer Overflows
  • SECTRACK ID: 1019159: OpenPegasus Stack Overflow in PAM Authentication Lets Remote Users Execute Arbitrary Code

Platforms Affected:

  • HP HP-UX 11.11
  • HP HP-UX 11.23
  • HP HP-UX 11.31
  • Open Group OpenPegasus 2.7
  • RedHat Enterprise Linux 4 WS
  • RedHat Enterprise Linux 4 Desktop
  • RedHat Enterprise Linux 4 AS
  • RedHat Enterprise Linux 4 ES
  • RedHat Enterprise Linux 4.5.z AS
  • RedHat Enterprise Linux 4.5.z ES
  • RedHat Enterprise Linux 4.6.z ES
  • RedHat Enterprise Linux 4.6.z AS
  • RedHat Enterprise Linux 5 Client Workstation
  • RedHat Enterprise Linux 5
  • RedHat Enterprise Linux 5 Client
  • RedHat Enterprise Linux 5.1.z EUS

Reported:

Jan 07, 2008

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page

* According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall IBM be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

About IBM Internet Security Systems

IBM Internet Security Systems is a trusted security advisor to thousands of the world's leading businesses and governments, helping to provide pre-emptive protection for networks, desktops and servers. The IBM Proventia? integrated security platform is designed to automatically protect against both known and unknown threats, helping to keep networks up and running and shield customers from online attacks before they impact business assets. IBM Internet Security Systems products and services are based on the proactive security intelligence of its X-Force? research and development team ? an unequivocal world authority in vulnerability and threat research. The IBM Internet Security Systems product line is also complemented by comprehensive Managed Security Services and Professional Security Services. For more information, visit the IBM Internet Security Systems Web site at www.iss.net or call 800-776-2362.