ZoneMinder unspecified code execution

zoneminder-unspecified-code-execution (42046) The risk level is classified as HighHigh Risk

Description:

An unspecified vulnerability in ZoneMinder could allow a remote authenticated attacker to execute arbitrary code on the system with "web user" privileges using unknown attack vectors.

*CVSS:

Base Score: 6
  Access Vector: Network
  Access Complexity: Medium
  Authentication: Single
  Confidentiality Impact: Partial
  Integrity Impact: Partial
  Availability Impact: Partial
 
Temporal Score: 4.4
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of ZoneMinder (1.23.3 or later), available from the ZoneMinder Web site. See References.

References:

  • ZoneMinder Change History, Release 1.23.3: Import security fixes and other minor changes.
  • ZoneMinder Web site: Downloads.
  • BID-28968: ZoneMinder Multiple Unspecified Remote Code Execution Vulnerabilities
  • CVE-2008-1381: ZoneMinder before 1.23.3 allows remote authenticated users, and possibly unauthenticated attackers in some installations, to execute arbitrary commands via shell metacharacters in a crafted URL.
  • OSVDB ID: 44605: ZoneMinder Multiple Unspecified Arbitrary Remote Code Execution
  • SA29995: ZoneMinder Unspecified Code Execution Vulnerabilities

Platforms Affected:

  • ZoneMinder ZoneMinder 0.0.1
  • ZoneMinder ZoneMinder 0.9.10
  • ZoneMinder ZoneMinder 0.9.11
  • ZoneMinder ZoneMinder 0.9.12
  • ZoneMinder ZoneMinder 0.9.13
  • ZoneMinder ZoneMinder 0.9.14
  • ZoneMinder ZoneMinder 0.9.15
  • ZoneMinder ZoneMinder 0.9.16
  • ZoneMinder ZoneMinder 0.9.7
  • ZoneMinder ZoneMinder 0.9.8
  • ZoneMinder ZoneMinder 0.9.9
  • ZoneMinder ZoneMinder 1.17.0
  • ZoneMinder ZoneMinder 1.17.2
  • ZoneMinder ZoneMinder 1.18.0
  • ZoneMinder ZoneMinder 1.18.1
  • ZoneMinder ZoneMinder 1.19.0
  • ZoneMinder ZoneMinder 1.19.1
  • ZoneMinder ZoneMinder 1.19.2
  • ZoneMinder ZoneMinder 1.19.3
  • ZoneMinder ZoneMinder 1.19.4
  • ZoneMinder ZoneMinder 1.19.5
  • ZoneMinder ZoneMinder 1.20.0
  • ZoneMinder ZoneMinder 1.20.1
  • ZoneMinder ZoneMinder 1.21.0
  • ZoneMinder ZoneMinder 1.21.1
  • ZoneMinder ZoneMinder 1.21.2
  • ZoneMinder ZoneMinder 1.21.3
  • ZoneMinder ZoneMinder 1.21.4
  • ZoneMinder ZoneMinder 1.22.0
  • ZoneMinder ZoneMinder 1.22.1
  • ZoneMinder ZoneMinder 1.22.2
  • ZoneMinder ZoneMinder 1.22.3
  • ZoneMinder ZoneMinder 1.23.0
  • ZoneMinder ZoneMinder 1.23.1
  • ZoneMinder ZoneMinder 1.23.2

Reported:

Apr 28, 2008

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page