MOStlyContent Editor component for Mambo unspecified cross-site scripting
|mostlyce-unspecified-xss (42749)||Medium Risk|
The MOStlyContent Editor (MOStlyCE) component for Mambo is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability using an unspecified parameter in a specially-crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.
Upgrade to the latest version of the MOStlyContent Editor component for Mambo (4.6.4 or later), available from the Mambo Web site. See References.
- Mambo CMS Forum, 24-05-2008, 02:40 PM: Please upgrade your sites to Mambo 4.6.4.
- Mambo Web site: Mambo > Projects > Mambo CMS > Files > Browse Frs Package.
- CVE-2008-2500: Cross-site scripting (XSS) vulnerability in the MOStlyContent Editor (MOStlyCE) component before 3.0 for Mambo allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- OSVDB ID: 45725: MOStlyCE for Mambo Multiple Unspecified XSS
- Mamboserver MOStlyCE component for Mambo 2.0
- Mamboserver MOStlyCE component for Mambo 2.2
- Mamboserver MOStlyCE component for Mambo 2.3
May 24, 2008
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.
For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this