Telephone Directory 2008 del_query1.php id parameter weak security

telephonedirectory2008-id-weak-security (42973) The risk level is classified as MediumMedium Risk

Description:

Telephone Directory 2008 could provide weaker than expected security, caused by improper validation of user-supplied input by the del_query1.php script. A remote attacker could exploit this vulnerability using the id parameter to delete arbitrary contacts.

*CVSS:

Base Score: 5
  Access Vector: Network
  Access Complexity: Low
  Authentication: None
  Confidentiality Impact: None
  Integrity Impact: Partial
  Availability Impact: None
 
Temporal Score: 4.8
  Exploitability: High
  Remediation Level: Unavailable
  Report Confidence: Uncorroborated

Consequences:

Other

Remedy:

No remedy available as of September 1, 2014.

References:

  • SourceForge.net: Telephone Directory 2008.
  • CVE-2008-7180: del_query1.php in Telephone Directory 2008 allows remote attackers to delete arbitrary contacts via a direct request with a modified id variable.
  • OSVDB ID: 57826: Telephone Directory 2008 del_query1.php id Parameter Arbitrary Contact Deletion

Platforms Affected:

  • Telephone Directory 2008 Telephone Directory 2008

Reported:

Jun 09, 2008

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page