FlashGet FTP PWD buffer overflow

flashget-ftppwd-bo (44443) The risk level is classified as HighHigh Risk

Description:

FlashGet is vulnerable to a stack-based buffer overflow, caused by improper bounds checking when processing FTP PWD responses. By persuading a victim to connect to a malicious FTP server, a remote attacker could overflow a buffer and execute arbitrary code on the system.

*CVSS:

Base Score: 9.3
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: Complete
  Integrity Impact: Complete
  Availability Impact: Complete
 
Temporal Score: 8.4
  Exploitability: Functional
  Remediation Level: Unavailable
  Report Confidence: Uncorroborated

Consequences:

Gain Access

Remedy:

No remedy available as of September 1, 2014.

References:

  • FlashGet Web site: Best Download Manager - FlashGet.
  • BID-30685: FlashGet FTP 'PWD' Response Remote Buffer Overflow Vulnerability
  • CVE-2008-4321: Buffer overflow in FlashGet (formerly JetCar) FTP 1.9 allows remote FTP servers to execute arbitrary code via a long response to the PWD command.
  • OSVDB ID: 47457: FlashGet FTP PWD Response Handling Overflow
  • SA31481: FlashGet FTP PWD Buffer Overflow Vulnerability

Platforms Affected:

  • Amaze Software FlashGet 1.9.0.1012

Reported:

Aug 13, 2008

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page