Compress::Raw::Zlib module for Perl inflate() function buffer overflow

perl-compressrawzlib-inflate-bo (51062) The risk level is classified as HighHigh Risk

Description:

The Compress::Raw::Zlib module for Perl is vulnerable to a heap-based buffer overflow, caused by an off-by-one error in the inflate() function. By persuading a victim to open a .zip file containing a specially-crafted zlib-stream, a remote attacker could overflow a buffer and execute arbitrary code on the system with elevated privileges or cause the affected application to crash.

*CVSS:

Base Score: 6.8
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: Partial
  Integrity Impact: Partial
  Availability Impact: Partial
 
Temporal Score: 5
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of Compress::Raw::Zlib (2.017 or later), available from the Paul Marquess Compress-Raw-Zlib Web site. See References.

References:

  • Paul Marquess Compress-Raw-Zlib Web site: Compress::Raw::Zlib.
  • Red Hat Bugzilla Bug 504386: CVE-2009-1391 Buffer overflow in Compress::Raw::Zlib.
  • BID-35307: 'Compress::Raw::Zlib' Perl Module Remote Code Execution Vulnerability
  • CVE-2009-1391: Off-by-one error in the inflate function in Zlib.xs in Compress::Raw::Zlib Perl module before 2.017, as used in AMaViS, SpamAssassin, and possibly other products, allows context-dependent attackers to cause a denial of service (hang or crash) via a crafted zlib compressed stream that triggers a heap-based buffer overflow, as exploited in the wild by Trojan.Downloader-71014 in June 2009.
  • OSVDB ID: 55041: Perl Compress::Raw::Zlib Module Zlib.xs inflate() Function Overflow
  • OSVDB ID: 57174: Perl Compress::Raw::Bzip2 Module Bzip2.xs bzinflate() Function Off-by-One Overflow
  • SA35422: Perl Compress::Raw::Zlib Module Off-by-One Vulnerability
  • SA36386: Perl Compress::Raw::Bzip2 Module Off-by-One Vulnerability
  • SA37534: ActivePerl Compress Modules Off-by-One Vulnerabilities
  • SUSE-SR:2009:012: SUSE Security Summary Report
  • USN-794-1: Perl vulnerability

Platforms Affected:

  • Canonical Ubuntu 8.04 LTS
  • Canonical Ubuntu 8.10
  • Paul Marquess Compress::Raw::Zlib 2.014
  • Paul Marquess Compress::Raw::Zlib 2.015

Reported:

Jun 11, 2009

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page