Google Chrome JavaScript buffer overflow

googlechrome-javascript-bo (51801) The risk level is classified as HighHigh Risk

Description:

Google Chrome is vulnerable to a heap-based buffer overflow, caused by improper bounds checking by src/jsregexp.cc in Google V8 when evaluating regular expressions in JavaScript. By persuading a victim to visit a specially-crafted Web site, a remote attacker could overflow a buffer and execute arbitrary code in the Google Chrome sandbox or cause the renderer (tab) to crash.

*CVSS:

Base Score: 6.8
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: Partial
  Integrity Impact: Partial
  Availability Impact: Partial
 
Temporal Score: 5
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of Google Chrome (2.0.172.37 or later), available from the Google Chrome Web site. See References.

References:

  • Google Chrome Releases Blog: Stable, Beta update: Bug fixes.
  • Google Chrome Web site: Google Chrome.
  • BID-35722: Google Chrome JavaScript Regular Expression Handling Remote Code Execution Vulnerability
  • CVE-2009-2555: Heap-based buffer overflow in src/jsregexp.cc in Google V8 before 1.1.10.14, as used in Google Chrome before 2.0.172.37, allows remote attackers to execute arbitrary code in the Chrome sandbox via a crafted JavaScript regular expression.
  • OSVDB ID: 55939: Google Chrome JavaScript Regular Expressions Evaluation Memory Corruption
  • SA35844: Google Chrome JavaScript Regular Expressions Memory Corruption

Platforms Affected:

  • Google Chrome 0.2.149.27
  • Google Chrome 0.2.149.29
  • Google Chrome 0.2.149.30
  • Google Chrome 0.2.152.1
  • Google Chrome 0.2.153.1
  • Google Chrome 0.3.154.0
  • Google Chrome 0.3.154.3
  • Google Chrome 0.3.154.9
  • Google Chrome 0.4.154.18
  • Google Chrome 0.4.154.22
  • Google Chrome 0.4.154.31
  • Google Chrome 0.4.154.33
  • Google Chrome 1.0.154.36
  • Google Chrome 1.0.154.39
  • Google Chrome 1.0.154.42
  • Google Chrome 1.0.154.43
  • Google Chrome 1.0.154.46
  • Google Chrome 1.0.154.48
  • Google Chrome 1.0.154.52
  • Google Chrome 1.0.154.53
  • Google Chrome 1.0.154.55
  • Google Chrome 1.0.154.59
  • Google Chrome 1.0.154.61
  • Google Chrome 1.0.154.64
  • Google Chrome 1.0.154.65
  • Google Chrome 2.0.156.1
  • Google Chrome 2.0.157.0
  • Google Chrome 2.0.157.2
  • Google Chrome 2.0.158.0
  • Google Chrome 2.0.159.0
  • Google Chrome 2.0.172.30
  • Google Chrome 2.0.172.31
  • Google Chrome 2.0.172.33

Reported:

Jul 16, 2009

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page