Webform module for Drupal cache information disclosure

drupal-webform-cache-info-disclosure (53797) The risk level is classified as LowLow Risk

Description:

The Webform module for Drupal could allow an attacker to obtain sensitive information, caused by the failure to prevent the page from being cached when a default value uses token placeholders. If caching is enabled, a remote attacker could exploit this vulnerability to obtain session variables.

*CVSS:

Base Score: 5
  Access Vector: Network
  Access Complexity: Low
  Authentication: None
  Confidentiality Impact: None
  Integrity Impact: Partial
  Availability Impact: None
 
Temporal Score: 4.4
  Exploitability: High
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Obtain Information

Remedy:

Refer to DRUPAL-SA-CONTRIB-2009-074 for patch, upgrade or suggested workaround information. See References.

References:

  • DRUPAL-SA-CONTRIB-2009-074: Webform - Multiple vulnerabilities.
  • BID-36708: Drupal Webform Module HTML Injection and Information Disclosure Vulnerabilities
  • CVE-2009-4533: The Webform module 5.x before 5.x-2.8 and 6.x before 6.x-2.8, a module for Drupal, does not prevent caching of a page that contains token placeholders for a default value, which allows remote attackers to read session variables via unspecified vectors.
  • OSVDB ID: 58946: Webform Module for Drupal Cached Page Handling Session Variable Disclosure
  • SA37021: Drupal Webform Module Script Insertion and Information Disclosure Vulnerabilities

Platforms Affected:

  • Drupal webform module 5.x-2.1
  • Drupal webform module 5.x-2.1-1
  • Drupal webform module 5.x-2.1.2
  • Drupal webform module 5.x-2.1.3
  • Drupal webform module 5.x-2.2
  • Drupal webform module 5.x-2.3
  • Drupal webform module 5.x-2.4
  • Drupal webform module 5.x-2.5
  • Drupal webform module 5.x-2.6
  • Drupal webform module 5.x-2.7
  • Drupal webform module 6.x-2.1-1
  • Drupal webform module 6.x-2.1.2
  • Drupal webform module 6.x-2.1.3
  • Drupal webform module 6.x-2.2
  • Drupal webform module 6.x-2.3
  • Drupal webform module 6.x-2.4
  • Drupal webform module 6.x-2.5
  • Drupal webform module 6.x-2.6
  • Drupal webform module 6.x-2.7

Reported:

Oct 15, 2009

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page