WP-Cumulus plugin for WordPress tagcloud cross-site scripting

wpcumulus-tagcloud-xss (54397) The risk level is classified as MediumMedium Risk

Description:

The WP-Cumulus plugin for WordPress is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by tagcloud.swf. file. A remote attacker could exploit this vulnerability using the tagcloud parameter in a specially-crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

*CVSS:

Base Score: 4.3
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: None
  Integrity Impact: Partial
  Availability Impact: None
 
Temporal Score: 3.7
  Exploitability: High
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of WP-Cumulus plugin (1.23 or later), available from the WordPress Web site. See References.

References:

  • BugTraq Mailing List, Sat Nov 21 2009: Vulnerabilities in plugins for WordPress.
  • Websecurity - Web Security Web Site: Vulnerability in WP-Cumulus for WordPress.
  • WordPress Web site: WP-Cumulus.
  • BID-37100: WordPress WP-Cumulus Plugin 'tagcloud.swf' Cross-Site Scripting Vulnerability
  • BID-37102: WordPress WP-Cumulus Plugin Cross-Site Scripting Vulnerability
  • BID-37479: Joomla! Joomulus Component 'tagcloud.swf' Cross-Site Scripting Vulnerability
  • CVE-2009-4168: Cross-site scripting (XSS) vulnerability in Roy Tanck tagcloud.swf, as used in the WP-Cumulus plugin before 1.23 for WordPress and the Joomulus module 2.0 and earlier for Joomla!, allows remote attackers to inject arbitrary web script or HTML via the tagcloud parameter in a tags action. Cross-site scripting (XSS) vulnerability in tagcloud.swf in the WP-Cumulus Plug-in before 1.23 for WordPress allows remote attackers to inject arbitrary web script or HTML via the tagcloud parameter.
  • CVE-2009-4169: Cross-site scripting (XSS) vulnerability in wp-cumulus.php in the WP-Cumulus Plug-in before 1.22 for WordPress allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
  • OSVDB ID: 60497: WP-Cumulus Plugin for WordPress wp-content/plugins/wp-cumulus/tagcloud.swf tagcloud Parameter XSS
  • OSVDB ID: 60627: WP-Cumulus Plugin for WordPress Unspecified XSS
  • SA37483: WordPress WP-Cumulus Plugin "tagcloud" Cross-Site Scripting Vulnerability
  • SA38161: Joomla! JVClouds3D Module "tagcloud" Cross-Site Scripting Vulnerability

Platforms Affected:

  • WordPress WP-Cumulus Plugin for WordPress 1.00
  • WordPress WP-Cumulus Plugin for WordPress 1.01
  • WordPress WP-Cumulus Plugin for WordPress 1.02
  • WordPress WP-Cumulus Plugin for WordPress 1.03
  • WordPress WP-Cumulus Plugin for WordPress 1.04
  • WordPress WP-Cumulus Plugin for WordPress 1.05
  • WordPress WP-Cumulus Plugin for WordPress 1.10
  • WordPress WP-Cumulus Plugin for WordPress 1.11
  • WordPress WP-Cumulus Plugin for WordPress 1.12
  • WordPress WP-Cumulus Plugin for WordPress 1.13
  • WordPress WP-Cumulus Plugin for WordPress 1.14
  • WordPress WP-Cumulus Plugin for WordPress 1.15
  • WordPress WP-Cumulus Plugin for WordPress 1.16
  • WordPress WP-Cumulus Plugin for WordPress 1.17
  • WordPress WP-Cumulus Plugin for WordPress 1.18
  • WordPress WP-Cumulus Plugin for WordPress 1.19
  • WordPress WP-Cumulus Plugin for WordPress 1.20
  • WordPress WP-Cumulus Plugin for WordPress 1.21
  • WordPress WP-Cumulus Plugin for WordPress 1.22

Reported:

Sep 11, 2009

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page

* According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall IBM be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

About IBM Security Systems

IBM Security Systems include an extensive portfolio of hardware, software solutions, professional and managed services offerings covering the spectrum of IT and business security risks: people and identity, data and information, application and process, network, server and endpoint and physical infrastructure, empowering clients to innovate and operate their businesses on the most secure infrastructure platforms. Through world-class solutions that address risk across the enterprise, IBM helps organizations build a strong security posture that helps reduce costs, improve service, and manage risk. IBM X-Force(R) Research and Development is one of the most renowned commercial security research and development groups in the world. For more information on how to address today's biggest risks, please visit us at ibm.com/security.