OpenOffice.org XPM file buffer overflow

openoffice-xpm-bo (56236) The risk level is classified as HighHigh Risk

Description:

OpenOffice.org is vulnerable to a heap-based buffer overflow, caused by an integer overflow error in XPMReader::ReadXPM. By persuading a victim to open a specially-crafted XPM image file, a remote attacker could overflow a buffer and execute arbitrary code on the system or cause the application to crash.

*CVSS:

Base Score: 6.8
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: Partial
  Integrity Impact: Partial
  Availability Impact: Partial
 
Temporal Score: 5
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of OpenOffice.org (3.2 or later), available from the OpenOffice.org Web site. See References.

Apply the appropriate update for your system. See References.

References:

  • OpenOffice Web Site: Security Vulnerability in OpenOffice.org related to XPM file processing.
  • Oracle Critical Patch Update Advisory - October 2010: Oracle Critical Patch Update Advisory - October 2010.
  • Red Hat Bugzilla Bug 527540: (CVE-2009-2949) CVE-2009-2949 openoffice.org: integer overflow in XPM processing.
  • BID-38218: OpenOffice Prior to 3.2 Multiple Remote Code Execution Vulnerabilities
  • CVE-2009-2949: Integer overflow in the XPMReader::ReadXPM function in filter.vcl/ixpm/svt_xpmread.cxx in OpenOffice.org (OOo) before 3.2 allows remote attackers to execute arbitrary code via a crafted XPM file that triggers a heap-based buffer overflow.
  • DSA-1995: openoffice.org -- several vulnerabilities
  • MDVSA-2010:221: openoffice.org
  • RHSA-2010-0101: Important: openoffice.org security update
  • SA38567: OpenOffice.org 2 Multiple Vulnerabilities
  • SA38568: OpenOffice.org 3 Multiple Vulnerabilities
  • SA41818: Oracle Open Office Multiple Vulnerabilities
  • SECTRACK ID: 1023591: OpenOffice.org Flaws Let Remote Users Execute Arbitrary Code
  • SUSE-SA:2010:017: OpenOffice.org security update
  • USN-903-1: OpenOffice.org vulnerabilities
  • VUPEN/ADV-2010-0366: OpenOffice.org Data Processing Multiple Code Execution Vulnerabilities
  • VUPEN/ADV-2010-0635: SuSE Security Update Fixes OpenOffice Code Execution Vulnerabilities

Platforms Affected:

  • Canonical Ubuntu 8.04 LTS
  • Canonical Ubuntu 8.10
  • Debian Debian Linux 4.0
  • Debian Debian Linux 5.0
  • Mandriva Enterprise Server 5 X86_64
  • Mandriva Enterprise Server 5
  • Mandriva Linux 2009.0 X86_64
  • Mandriva Linux 2009.0
  • Mandriva Linux 2010 X86_64
  • Mandriva Linux 2010
  • Novell Linux Desktop 9
  • Novell OpenSUSE 11.0
  • Novell SLE SDK 10
  • Novell SLE SDK 10 SP2
  • Novell SUSE Linux Enterprise Desktop 10 SP2
  • OpenOffice OpenOffice.org 3.1.0
  • RedHat Enterprise Linux 3 Desktop
  • RedHat Enterprise Linux 3 ES
  • RedHat Enterprise Linux 3 WS
  • RedHat Enterprise Linux 3 AS
  • RedHat Enterprise Linux 4 WS
  • RedHat Enterprise Linux 4 Desktop
  • RedHat Enterprise Linux 4 ES
  • RedHat Enterprise Linux 4 AS
  • RedHat Enterprise Linux 4.8.z AS
  • RedHat Enterprise Linux 4.8.z ES
  • RedHat Enterprise Linux 5 Client
  • RedHat Enterprise Linux 5 Client Workstation
  • RedHat Enterprise Linux Optional Productivity Applications 5 Server
  • RedHat RHEL Optional Productivity Applications 5.4.z EUS

Reported:

Feb 15, 2010

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page

* According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.
The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall IBM be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

About IBM Internet Security Systems

IBM Internet Security Systems is a trusted security advisor to thousands of the world's leading businesses and governments, helping to provide pre-emptive protection for networks, desktops and servers. The IBM Proventia? integrated security platform is designed to automatically protect against both known and unknown threats, helping to keep networks up and running and shield customers from online attacks before they impact business assets. IBM Internet Security Systems products and services are based on the proactive security intelligence of its X-Force? research and development team ? an unequivocal world authority in vulnerability and threat research. The IBM Internet Security Systems product line is also complemented by comprehensive Managed Security Services and Professional Security Services. For more information, visit the IBM Internet Security Systems Web site at www.iss.net or call 800-776-2362.