Workflow module for Drupal Comment field cross-site scripting

workflow-comment-xss (56638) The risk level is classified as MediumMedium Risk

Description:

Workflow module for Drupal, when used with the Token module, is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. If specific configuration settings are enabled, a remote attacker could exploit this vulnerability using the comment field of the workflow fieldset on the node form to inject malicious script into a Web page which would be executed in a victim's Web browser within the security context of the hosting Web site, once the page is viewed. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

*CVSS:

Base Score: 4.3
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: None
  Integrity Impact: Partial
  Availability Impact: None
 
Temporal Score: 3.7
  Exploitability: High
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Refer to SA-CONTRIB-2010-023 for patch, upgrade or suggested workaround information. See References.

References:

  • SA-CONTRIB-2010-023: Workflow - Cross Site Scripting.
  • BID-38520: Drupal Workflow Module Comment Field HTML Injection Vulnerability
  • CVE-2010-1539: Cross-site scripting (XSS) vulnerability in the Workflow module 5.x-2.x before 5.x-2.6 and 6.x-1.x before 6.x-1.4 for Drupal, when used with the Token module, might allow remote authenticated users to inject arbitrary web script or HTML via a certain Comment field.
  • OSVDB ID: 62722: Workflow Module for Drupal Unspecified XSS
  • SA38825: Drupal Workflow Module Script Insertion Vulnerability
  • SA38835: Drupal Multiple Vulnerabilities

Platforms Affected:

  • Drupal Drupal
  • Drupal Workflow module for Drupal 5.x-2.0
  • Drupal Workflow module for Drupal 5.x-2.1
  • Drupal Workflow module for Drupal 5.x-2.2
  • Drupal Workflow module for Drupal 5.x-2.3
  • Drupal Workflow module for Drupal 5.x-2.4
  • Drupal Workflow module for Drupal 5.x-2.5
  • Drupal Workflow module for Drupal 6.x-1.0 rc1
  • Drupal Workflow module for Drupal 6.x-1.0 rc3
  • Drupal Workflow module for Drupal 6.x-1.0 rc4
  • Drupal Workflow module for Drupal 6.x-1.0 beta1
  • Drupal Workflow module for Drupal 6.x-1.0 beta2
  • Drupal Workflow module for Drupal 6.x-1.0
  • Drupal Workflow module for Drupal 6.x-1.1
  • Drupal Workflow module for Drupal 6.x-1.2
  • Drupal Workflow module for Drupal 6.x-1.3

Reported:

Mar 03, 2010

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page