IPC@CHIP "chipcfg.cgi" allows remote attacker to gain sensitive information

ipcchip-chipcfg-gain-information (6600) The risk level is classified as MediumMedium Risk

Description:

IPC@CHIP could allow a remote attacker to obtain sensitive network information. By default, the chipcfg.cgi script is installed. A remote attacker can send a specially-crafted URL request containing the chipcfg.cgi script to the server to gain access to sensitive network information.


Consequences:

Obtain Information

Remedy:

No remedy available as of August 1, 2014.

References:

  • BugTraq Mailing List, Thu May 24 2001 - 10:10:40 CDT: IPC@Chip Security.
  • Sentry Research Labs: IPC@CHIP Security Report v0.2.
  • BID-2767: Beck IPC GmbH IPC@CHIP Network Information Disclosure Vulnerability
  • CVE-2001-1341: The Beck GmbH IPC@Chip embedded web server installs the chipcfg.cgi program by default, which allows remote attackers to obtain sensitive network information via a request to the program.
  • OSVDB ID: 14268: BecK IPC GmbH IPC@Chip Web Server chipcfg.cgi Information Disclosure
  • US-CERT VU#574739: Beck GmbH IPC@Chip does not adequately validate user input thereby disclosing sensitive network data via crafted URL

Platforms Affected:

  • Beck IPC GmbH IPC@CHIP

Reported:

May 21, 2001

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page